



<!DOCTYPE html>
<html lang="en">
  <head>
    <title>What do NFL Draft analysts think of the prospects visiting the Broncos? - Mile High Report</title>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <meta name="apple-mobile-web-app-title" content="Mile High Report" />
    
    
      <meta property="article:publisher" content="http://www.facebook.com/MileHighReport" />
  <meta property="author" content="Just_JoRo" />
  <meta property="article:published_time" content="2022-04-09T04:00:00-06:00" />
  <meta property="article:modified_time" content="2022-04-09T04:00:00-06:00" />

    

  
    <link rel="preload" href="https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukText-MediumItalic-Web.woff2" as="font" type="font/woff2" crossorigin>
  

  
    <link rel="preload" href="https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukText-Medium-Web.woff2" as="font" type="font/woff2" crossorigin>
  

  
    <link rel="preload" href="https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukText-BoldItalic-Web.woff2" as="font" type="font/woff2" crossorigin>
  

  
    <link rel="preload" href="https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukText-Bold-Web.woff2" as="font" type="font/woff2" crossorigin>
  

  
    <link rel="preload" href="https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-MediumItalic-Web.woff2" as="font" type="font/woff2" crossorigin>
  

  
    <link rel="preload" href="https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-Medium-Web.woff2" as="font" type="font/woff2" crossorigin>
  

  
    <link rel="preload" href="https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-BoldItalic-Web.woff2" as="font" type="font/woff2" crossorigin>
  

  
    <link rel="preload" href="https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-Bold-Web.woff2" as="font" type="font/woff2" crossorigin>
  

  
    <link rel="preload" href="https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-SuperItalic-Web.woff2" as="font" type="font/woff2" crossorigin>
  

  
    <link rel="preload" href="https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-Super-Web.woff2" as="font" type="font/woff2" crossorigin>
  

  
    <link rel="preload" href="https://cdn.vox-cdn.com/shared_fonts/unison/unison_base/nittigrotesk/nittigrotesk-normal.woff2" as="font" type="font/woff2" crossorigin>
  



<link rel="preconnect" href="https://use.typekit.net">


<meta id="chorus-fonts" data-cid="site/font_loader-1649516362_3962_296535" data-cdata='{"version":"1c5dba5203ab569c8e4b65c70e7b0c88","fonts_catalog":[{"slug":"sbn-druk","family":"Druk Text Web","weight":"500","style":"italic","woff2_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukText-MediumItalic-Web.woff2","woff_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukText-MediumItalic-Web.woff"},{"slug":"sbn-druk","family":"Druk Text Web","weight":"500","style":"normal","woff2_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukText-Medium-Web.woff2","woff_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukText-Medium-Web.woff"},{"slug":"sbn-druk","family":"Druk Text Web","weight":"700","style":"italic","woff2_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukText-BoldItalic-Web.woff2","woff_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukText-BoldItalic-Web.woff"},{"slug":"sbn-druk","family":"Druk Text Web","weight":"700","style":"normal","woff2_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukText-Bold-Web.woff2","woff_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukText-Bold-Web.woff"},{"slug":"sbn-druk-wide","family":"Druk Text Wide Web","weight":"500","style":"italic","woff2_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-MediumItalic-Web.woff2","woff_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-MediumItalic-Web.woff"},{"slug":"sbn-druk-wide","family":"Druk Text Wide Web","weight":"500","style":"normal","woff2_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-Medium-Web.woff2","woff_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-Medium-Web.woff"},{"slug":"sbn-druk-wide","family":"Druk Text Wide Web","weight":"700","style":"italic","woff2_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-BoldItalic-Web.woff2","woff_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-BoldItalic-Web.woff"},{"slug":"sbn-druk-wide","family":"Druk Text Wide Web","weight":"700","style":"normal","woff2_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-Bold-Web.woff2","woff_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-Bold-Web.woff"},{"slug":"sbn-druk-wide","family":"Druk Text Wide Web","weight":"900","style":"italic","woff2_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-SuperItalic-Web.woff2","woff_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-SuperItalic-Web.woff"},{"slug":"sbn-druk-wide","family":"Druk Text Wide Web","weight":"900","style":"normal","woff2_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-Super-Web.woff2","woff_url":"https://cdn.vox-cdn.com/shared_fonts/unison/sbn/druk/DrukTextWide-Super-Web.woff"},{"slug":"unison-nitti","family":"nitti-grotesk","weight":"400","style":"normal","woff2_url":"https://cdn.vox-cdn.com/shared_fonts/unison/unison_base/nittigrotesk/nittigrotesk-normal.woff2","woff_url":"https://cdn.vox-cdn.com/shared_fonts/unison/unison_base/nittigrotesk/nittigrotesk-normal.woff"}],"font_stylesheets":["https://fonts.voxmedia.com/unison/stylesheets/sbn.0289821fe196f0ced638117948a0d46f.css"],"font_tracker_stylesheets":[],"typekit_ids":[],"headline_balance_div_classes":"","headline_balance_fraction":1.0}'>

    <script>var chorusInitQueue=[],volume_embed_host="https://volume.vox-cdn.com";var Chorus=Chorus||{};Chorus.windowLoaded=!1,Chorus.AddScript=function(t,e){var o=document.createElement("script");o.async=!0,o.type="text/javascript",o.src=t,"function"==typeof e&&(o.onload=e);var a=document.getElementsByTagName("script")[0];return a.parentNode.insertBefore(o,a),o},Chorus.ready=function(t){"loading"!=document.readyState?t():document.addEventListener?document.addEventListener("DOMContentLoaded",t):document.attachEvent("onreadystatechange",function(){"loading"!=document.readyState&&t()})},Chorus.OnLoad=function(t){if(Chorus.windowLoaded=!0)return void t();var e=window.onload;"function"!=typeof window.onload?window.onload=t:window.onload=function(){e(),t()}},Chorus.OnLoad(function(){Chorus.windowLoaded=!0});var dataLayer=dataLayer||[];Chorus.OnLoad(function(){var t;void 0!==navigator.doNotTrack?t=navigator.doNotTrack:void 0!==window.doNotTrack?t=window.doNotTrack:void 0!==navigator.msDoNotTrack&&(t=navigator.msDoNotTrack),t=void 0!==t?/1|yes|true/.test(String(t).toLowerCase())?"true":"false":"undefined";var e={DNT:t};dataLayer.push(e)});var VoxMediaFontLoader=function(t){function e(t,e){var o=window.performance;if(o&&o.mark&&o.measure){var a=t.toLocaleLowerCase().replace(/\W+/g,"_")+(e?"_"+e:"");o.mark(a),o.measure(a+"_time","navigationStart",a)}}function o(){s.classList.add(c),e("fonts_success")}function a(){s.classList.add(c),e("fonts_fail")}function n(t){var o=[t.family,t.style,t.weight,"loaded"].join(" ");e(o)}function r(t){var e=u.font_stylesheets||[];t&&(e=e.filter(function(e){return!e.match(t)})),e.forEach(i)}function i(e){var o=t.createElement("link");o.href=e,o.rel="stylesheet",o.media="all",f.parentNode.insertBefore(o,f)}function d(e){var o,a=t,n=a.documentElement,r=setTimeout(function(){n.className=n.className.replace(/\bwf-loading\b/g,"")+" wf-inactive"},e.scriptTimeout),i=a.createElement("script"),d=!1,c=a.getElementsByTagName("script")[0];n.className+=" wf-loading",i.src="https://use.typekit.net/"+e.kitId+".js",i.async=!0,i.onload=i.onreadystatechange=function(){if(o=this.readyState,!(d||o&&"complete"!=o&&"loaded"!=o)){d=!0,clearTimeout(r);try{Typekit.load(e)}catch(t){}}},c.parentNode.insertBefore(i,c)}var c="fonts-loaded",s=t.documentElement,f=t.getElementById("chorus-fonts");if(f){var u=JSON.parse(f.getAttribute("data-cdata"));if(t.fonts){r("voxmedia.com");var l=[];u.fonts_catalog.forEach(function(e){if(e.woff2_url||e.woff_url){var o=[e.woff2_url,e.woff_url].filter(function(t){return t}).map(function(t){return"url("+t+")"}).join(", "),a=new FontFace(e.family,o,{weight:e.weight,style:e.style,display:"swap"});t.fonts.add(a),l.push(a.load())}}),l.length>0?Promise.allSettled(l).then(function(t){o(),t.filter(function(t){return"fulfilled"===t.status}).forEach(function(t){n(t.value)})})["catch"](function(){a()}):t.fonts.ready.then(o,a)}else r();u.typekit_ids.forEach(function(t){d({kitId:t,scriptTimeout:3e3,async:!0})}),u.font_tracker_stylesheets.forEach(i)}};VoxMediaFontLoader(document);</script>

    <script type="text/javascript">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</script>


<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-W8JKW6');</script>
<!-- End Google Tag Manager -->


    <link rel="dns-prefetch" href="https://pagead2.googlesyndication.com">
<link rel="dns-prefetch" href="https://securepubads.g.doubleclick.net">
<link rel="dns-prefetch" href="https://stats.g.doubleclick.net">
<link rel="dns-prefetch" href="https://www.google-analytics.com">
<link rel="dns-prefetch" href="https://cdn.permutive.com">
<link rel="dns-prefetch" href="https://mb.moatads.com">

<script>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</script>


      <link href="https://www.sbnation.com/style/community/55/a54680ce267f95dcf1f517c9018947d2/chorus.css" data-chorus-theme="chorus" rel="stylesheet" media="all">

    <meta name="style-tools" content="https://www.sbnation.com/style/community/55/6478abcbd3e948de0c662d30d6b242d4/tools.css">
    
    <script src="https://cdn.vox-cdn.com/packs/js/concert_ads-fd2115ac57be53617ff7.js" async="async" integrity="sha256-QueaxZef0/MORDX8IFdAYWgfveanId6RElI7cg2WqmY= sha384-zVeMqMedYQGS0XoJtlZ5U4AOsSPKm3eKUvwHqED50z23AVBHivuDAKoA0fRUziDc" crossorigin="anonymous"></script>
<script type="text/javascript">
  function instantiateConcertAds() {
    var concertAdsConfig = {
      cmd: window.concertAdsQueue
    };

    for (var property in window.CONCERT_ADS_CONFIG) {
      concertAdsConfig[property] = window.CONCERT_ADS_CONFIG[property];
    }

    window.concertAds = new ConcertAds(concertAdsConfig);
  }
</script>
<script src="https://cdn.concert.io/lib/concert-ads/v2-latest/concert_ads.js" onload="instantiateConcertAds()" async></script>
<script src="https://www.googletagservices.com/tag/js/gpt.js" async></script>

  <script src="https://cdn.concert.io/lib/concert-concierge.2.8.0.min.js" async></script>
  <script defer type="text/javascript" src="https://z.moatads.com/voxprebidheader841653991752/moatheader.js"></script>

    <script src="https://sejs.moatads.com/voxprebidheader841653991752/yi.js" async></script><meta name="msvalidate.01" content="D385D0326A3AE144205C298DB34B4E94">
    <meta name="description" content="We know half of the Broncos’ official 30 visits. What do they tell us about Paton’s plan for draft day?" />
<link rel="canonical" href="https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" />
<meta property="og:description" content="We know half of the Broncos’ official 30 visits. What do they tell us about Paton’s plan for draft day?" />
<meta property="fb:app_id" content="549923288395304" />
<meta property="og:image" content="https://cdn.vox-cdn.com/thumbor/inrokmusUq0vulGpNaANdr4erNU=/0x23:4908x2593/fit-in/1200x630/cdn.vox-cdn.com/uploads/chorus_asset/file/23375058/1238931000.jpg" />
<meta property="og:image:alt" content="NFL Combine" />
<meta property="og:image:height" content="630" />
<meta property="og:image:width" content="1200" />
<meta property="og:site_name" content="Mile High Report" />
<meta property="og:title" content="What do NFL Draft analysts say about the Broncos’ top 30 NFL Draft visits thus far?" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" />

      <meta name="twitter:card" content="summary_large_image" />
      <meta name="twitter:url" content="https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" />
      <meta name="twitter:title" content="What do NFL Draft analysts say about the Broncos’ top 30 NFL Draft visits thus far?" />
      <meta name="twitter:description" content="We know half of the Broncos’ official 30 visits. What do they tell us about Paton’s plan for draft day?" />
      <meta name="twitter:image" content="https://cdn.vox-cdn.com/thumbor/gs6FDj7zOTQ9PtDGwC2zIhFKCm4=/0x81:4908x2535/fit-in/1200x600/cdn.vox-cdn.com/uploads/chorus_asset/file/23375058/1238931000.jpg" />
      <meta name="twitter:site" content="MileHighReport" />
    <meta name="twitter:image:alt" content="NFL Combine">
<meta name="parsely-title" content="What do NFL Draft analysts say about the Broncos’ top 30 NFL Draft visits thus far?"></meta>
<meta name="parsely-link" content="https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"></meta>
<meta name="parsely-type" content="post"></meta>
<meta name="parsely-image-url" content="https://cdn.vox-cdn.com/thumbor/QSuDOJOSShsMKJkVaJOwQOFTeX4=/0x97:4908x2858/1600x900/cdn.vox-cdn.com/uploads/chorus_image/image/70729700/1238931000.0.jpg"></meta>
<meta name="parsely-pub-date" content="2022-04-09T04:00:00-06:00"></meta>
<meta name="parsely-section" content="front-page"></meta>
<meta name="parsely-tags" content="milehighreport,front-page,broncos-draft-class-2022"></meta>
<meta name="parsely-author" content="Just_JoRo"></meta>
<meta name="robots" content="max-image-preview:large" />
<script async defer src="https://go.metabet.io/js/global.js?siteID=draftkings-light:sbnation"></script>
    
  <link rel="shortcut icon" href="https://cdn3.vox-cdn.com/uploads/blog/favicon/55/favicon-96541d56.ico">


  

  

  
    <link rel="icon" type="image/png" href="https://cdn3.vox-cdn.com/uploads/blog/sbnu_logo_minimal/55/touch_icon_ipad_retina_milehighreport.com.minimal.83019.png" sizes="96x96">
  


  
    <link rel="icon" type="image/png" href="https://cdn3.vox-cdn.com/uploads/blog/sbnu_logo_minimal/55/touch_icon_ipad_retina_milehighreport.com.minimal.83019.png" sizes="192x192">
  


  
    <link rel="apple-touch-icon" href="https://cdn3.vox-cdn.com/uploads/blog/sbnu_logo_minimal/55/touch_icon_ipad_retina_milehighreport.com.minimal.83019.png" sizes="180x180">
  


  <meta name="msapplication-TileImage" content="https://cdn3.vox-cdn.com/uploads/blog/sbnu_logo_minimal/55/touch_icon_ipad_retina_milehighreport.com.minimal.83019.png">
  <meta name="msapplication-TileColor" content="#f05523">
  <meta name="theme-color" content="">


    <meta data-chorus-version="1649449326" />

    <link rel="amphtml" href="https://www.milehighreport.com/platform/amp/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far">

      <script class="coral-script" src="https://comments.milehighreport.com/assets/js/count.js?v=1626303173" defer></script>
    <link rel="alternate" type="application/rss+xml" title="Mile High Report" href="/rss/index.xml" />
    
      <script type="application/ld+json">
  {"@context":"http://schema.org","@type":"NewsArticle","mainEntityOfPage":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","url":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","headline":"What do NFL Draft analysts think of the prospects visiting the Broncos?","description":"We know half of the Broncos’ official 30 visits. What do they tell us about Paton’s plan for draft day?","speakable":{"@type":"SpeakableSpecification","xpath":["/html/head/title","/html/head/meta[@name='description']/@content"]},"datePublished":"2022-04-09T04:00:00-06:00","dateModified":"2022-04-09T04:00:00-06:00","author":[{"@type":"Person","name":"Just_JoRo"}],"publisher":{"@type":"Organization","name":"Mile High Report","logo":{"@type":"ImageObject","url":"https://cdn.vox-cdn.com/uploads/chorus_asset/file/13668549/google_amp.0.png","width":600,"height":60}},"articleSection":"Front Page","keywords":["Front Page","Denver Broncos 2022 Draft"],"image":[{"@type":"ImageObject","url":"https://cdn.vox-cdn.com/thumbor/juKqsFpcd7yCWjkHBL3y57NmInk=/1400x1400/filters:format(jpeg)/cdn.vox-cdn.com/uploads/chorus_asset/file/23375058/1238931000.jpg","width":1400,"height":1400},{"@type":"ImageObject","url":"https://cdn.vox-cdn.com/thumbor/OPq_ILFogIKZWNk6ZurOhJhwveE=/1400x1050/filters:format(jpeg)/cdn.vox-cdn.com/uploads/chorus_asset/file/23375058/1238931000.jpg","width":1400,"height":1050},{"@type":"ImageObject","url":"https://cdn.vox-cdn.com/thumbor/xwcIeo--I1QbBuzq2u3R5_ZRmCE=/1400x788/filters:format(jpeg)/cdn.vox-cdn.com/uploads/chorus_asset/file/23375058/1238931000.jpg","width":1400,"height":788}],"thumbnailUrl":"https://cdn.vox-cdn.com/thumbor/juKqsFpcd7yCWjkHBL3y57NmInk=/1400x1400/filters:format(jpeg)/cdn.vox-cdn.com/uploads/chorus_asset/file/23375058/1238931000.jpg"}
</script>


    <meta name="outbrainsection" content="broncos-draft-class-2022"></meta>
  </head>
  <!--[if lte IE 9]><body class="ie9"><![endif]-->
  <!--[if gte IE 10]><body class="ie"><![endif]-->
  <body class="entry_key_unison_standard entry_layout_unison_main entry_template_standard" data-entry-id="22779148">
    <a class="sr-only link-skip" href="#content">Skip to main content</a>
    <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W8JKW6" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

    
    
      <svg width="0" height="0" style="position:absolute;display:none;"><symbol viewbox="90 0 689 645" id="icon-clock" xmlns="http://www.w3.org/2000/svg"><title>clock</title>
<path d="M489.1 322.5c0 15-5.4 27.9-16 38.6-10.7 10.7-23.6 16-38.6 16-23.7 0-40.3-10.9-49.9-32.8h-125c-6.4 0-11.6-2.1-15.7-6.1-4-4.1-6.1-9.3-6.1-15.7 0-6.4 2.1-11.6 6.1-15.7 4.1-4.1 9.4-6.1 15.8-6.1h125c5.9-13.2 15.3-22.5 28-28V125.8c0-6.4 2.1-11.6 6.1-15.7 4.1-4.1 9.3-6.1 15.7-6.1 6.4 0 11.6 2 15.7 6.1s6.1 9.3 6.1 15.7v146.8c21.9 9.5 32.9 26.1 32.8 49.9zm-54.6-306c84.2 0 156.3 29.9 216.2 89.8 59.9 59.9 89.8 131.9 89.8 216.2s-29.9 156.3-89.8 216.2c-59.9 59.9-131.9 89.8-216.2 89.8s-156.3-29.9-216.2-89.8c-59.9-59.9-89.8-131.9-89.8-216.2s29.9-156.3 89.8-216.2c59.9-59.9 132-89.8 216.2-89.8zm0 546.4c66.5 0 123.2-23.4 170.1-70.4 46.9-46.9 70.4-103.6 70.4-170.1s-23.4-123.2-70.4-170.1C557.7 105.5 501 82.1 434.5 82.1s-123.2 23.4-170.1 70.4C217.5 199.4 194 256.1 194 322.6s23.4 123.2 70.4 170.1c46.9 46.8 103.6 70.2 170.1 70.2z"></path></symbol><symbol viewbox="0 0 1000 1000" id="icon-close" xmlns="http://www.w3.org/2000/svg"><path d="M638.6 500l322.7-322.7c38.3-38.3 38.3-100.3 0-138.6S861 .4 822.7 38.7L500 361.4 177.3 38.7C139 .4 77 .4 38.7 38.7S.4 139 38.7 177.3L361.4 500 38.7 822.7C.4 861 .4 923 38.7 961.3 57.9 980.4 82.9 990 108 990s50.1-9.6 69.3-28.7L500 638.6l322.7 322.7c19.1 19.1 44.2 28.7 69.3 28.7 25.1 0 50.1-9.6 69.3-28.7 38.3-38.3 38.3-100.3 0-138.6L638.6 500z"></path></symbol><symbol viewbox="0 0 14 14" id="icon-close-map" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" d="M13.074 12.27L7.698 6.958l5.376-5.312-.896-.896-5.312 5.376L1.554.75l-.896.864 5.376 5.312L.658 12.27l.896.896L6.898 7.79l5.312 5.376z"></path></symbol><symbol viewbox="0 0 18 17" id="icon-comment" xmlns="http://www.w3.org/2000/svg"><path d="M15.667 6.654c0 3.532-3.432 6.397-7.667 6.397-.945 0-1.85-.14-2.686-.4l-4.406 2.1 1.725-3.52c-1.42-1.16-2.3-2.78-2.3-4.56C.333 3.12 3.765.257 8 .257c4.235 0 7.667 2.863 7.667 6.4z"></path></symbol><symbol viewbox="-135.7 744.2 1008.1 429.7" id="icon-down" xmlns="http://www.w3.org/2000/svg"><path d="M872.3 788.5c0 12.1-5.1 25.2-18.2 35.3l-446 335c-12.1 10.1-28.3 15.2-40.4 15.2-15.2 0-28.3-5.1-40.4-15.2l-446.1-335c-18.2-15.2-22.2-40.4-10.1-60.5s40.4-22.2 58.5-10.1l439.1 330.9 435.9-331c18.2-15.2 45.4-10.1 58.5 10.1 7.2 8.1 9.2 15.1 9.2 25.3"></path></symbol><symbol viewbox="0 0 50.062 37.479" id="icon-email" xmlns="http://www.w3.org/2000/svg"><path d="M25.085 21.866L.082 3.114A3.114 3.114 0 0 1 3.207-.012H46.96a3.113 3.113 0 0 1 3.126 3.126l-25 18.752zm0 5.613L50.087 8.726v25.64a3.113 3.113 0 0 1-3.125 3.125H3.208a3.113 3.113 0 0 1-3.125-3.125V8.727L25.085 27.48z" class="afshape-1"></path></symbol><symbol viewbox="0 0 21.406 43.754" id="icon-facebook" xmlns="http://www.w3.org/2000/svg"><path d="M5.43 43.754v-20.53H0V15.83h5.43V9.518C5.43 4.558 8.635 0 16.024 0c2.99 0 5.204.286 5.204.286l-.175 6.903s-2.257-.03-4.72-.03c-2.663 0-3.09 1.23-3.09 3.26v5.4h8.022l-.35 7.39h-7.672v20.53H5.43z"></path></symbol><symbol viewbox="0 0 140 200" id="icon-foursquare" xmlns="http://www.w3.org/2000/svg"><path d="M114.697 27.581l-4.278 22.294c-.511 2.41-3.545 4.945-6.358 4.945h-39.7c-4.467 0-7.664 3.045-7.664 7.508v4.86c0 4.467 3.216 7.632 7.686 7.632h33.681c3.154 0 6.25 3.459 5.568 6.826-.685 3.373-3.886 20.08-4.271 21.924-.387 1.846-2.5 5-6.25 5H65.618c-5.007 0-6.521.654-9.87 4.818-3.353 4.166-33.477 40.342-33.477 40.342-.305.35-.603.249-.603-.134V27.25c0-2.85 2.478-6.194 6.194-6.194h81.78c3.01 0 5.822 2.829 5.055 6.525m3.59 87.418c1.137-4.602 13.899-69.93 18.16-90.656M120.716 0H18.809C4.745 0 .61 10.575.61 17.235v161.916c0 7.503 4.032 10.285 6.296 11.203 2.267.919 8.519 1.692 12.266-2.632 0 0 48.111-55.826 48.938-56.652 1.25-1.25 1.25-1.25 2.5-1.25h31.127c13.08 0 15.183-9.327 16.549-14.821 1.137-4.602 13.899-69.93 18.16-90.656C139.699 8.526 135.681 0 120.716 0"></path></symbol><symbol viewbox="-295 387 20 20" id="icon-full-screen" xmlns="http://www.w3.org/2000/svg"><path fill="#ccc" d="M-275 387.7c0-.2-.1-.4-.2-.5-.1-.1-.3-.2-.5-.2h-5.5c-.4 0-.7.3-.7.7 0 .4.4.8.6 1l1.4 1.4-3.9 3.9 1.9 1.9 3.9-3.9 1.4 1.4c.3.3.6.6 1 .6s.7-.3.7-.7l-.1-5.6zm-13.1 10.5l-3.9 4-1.4-1.4c-.3-.3-.6-.6-1-.6s-.6.3-.6.6v5.4c0 .2.1.4.2.5.1.1.3.2.5.2h5.4c.4 0 .6-.3.6-.6 0-.4-.4-.8-.6-.9l-1.4-1.4 4-3.9-1.8-1.9z"></path></symbol><symbol viewbox="-295 387 20 20" id="icon-full-screen-exit" xmlns="http://www.w3.org/2000/svg"><path fill="#ccc" d="M-293.2 406.9l3.9-4 1.4 1.4c.3.3.6.6 1 .6s.6-.3.6-.6v-5.4c0-.2-.1-.4-.2-.5-.1-.1-.3-.2-.5-.2h-5.4c-.4 0-.6.3-.6.6 0 .4.4.8.6.9l1.4 1.4-4 3.9 1.8 1.9zM-276.91 387.05l-3.9 4-1.4-1.4c-.3-.3-.6-.6-1-.6s-.6.3-.6.6v5.4c0 .2.1.4.2.5.1.1.3.2.5.2h5.4c.4 0 .6-.3.6-.6 0-.4-.4-.8-.6-.9l-1.4-1.4 4-3.9-1.8-1.9z"></path></symbol><symbol viewbox="0 0 39.605 39.633" id="icon-google-plus" xmlns="http://www.w3.org/2000/svg"><path d="M12.488 37.682c-4.69 0-8.08-2.97-8.08-6.537 0-3.496 3.976-6.51 8.667-6.46a10.21 10.21 0 0 1 3.04.488c2.547 1.77 4.6 2.876 5.117 4.894.096.41.15.83.15 1.26 0 3.567-2.3 6.355-8.894 6.355m1.233-21.46c-3.14-.093-6.14-2.982-6.68-7.116-.54-4.136 1.57-7.3 4.72-7.206 3.15.094 5.84 3.486 6.39 7.62.55 4.136-1.27 6.797-4.41 6.703m6.75 6.457c-1.08-.813-3.44-2.478-3.44-3.596 0-1.31.38-1.955 2.35-3.495 2.03-1.58 3.46-3.67 3.46-6.25 0-2.82-1.15-5.37-3.31-6.61h3.06L25.2 0H13.51C7.584 0 2.644 4.37 2.644 9.18c0 4.912 3.246 8.83 8.82 8.83.388 0 .764-.02 1.133-.048-.36.694-.62 1.467-.62 2.277 0 1.36.75 2.14 1.68 3.04-.702 0-1.38.02-2.12.02C4.75 23.3 0 27.97 0 32.46c0 4.412 5.726 7.173 12.513 7.173 7.737 0 12.495-4.39 12.495-8.8 0-3.54-.764-5.32-4.536-8.15M31.52.54v5.388h-5.388v2.695h5.39v5.39h2.694v-5.39h5.39V5.928h-5.39V.538"></path></symbol><symbol viewbox="0 0 105.4 105.7" class="alinline-svg" id="icon-grid" xmlns="http://www.w3.org/2000/svg"><path fill="#ccc" d="M0 0h47.7v47.7H0z" class="alshape-1"></path><path fill="#ccc" d="M57.7 0h47.7v47.7H57.7z" class="alshape-2"></path><path fill="#ccc" d="M0 58h47.7v47.7H0z" class="alshape-3"></path><path fill="#ccc" d="M57.7 58h47.7v47.7H57.7z" class="alshape-4"></path></symbol><symbol viewbox="0 0 64.37 40.34" id="icon-hamburger" xmlns="http://www.w3.org/2000/svg"><path class="amcls-1" d="M0 30h64.37v10.34H0zm0-15h64.37v10.34H0zM0 0h64.37v10.34H0z"></path></symbol><symbol viewbox="0 0 671.78668 671.78668" id="icon-instagram" xmlns="http://www.w3.org/2000/svg"><g transform="matrix(.13333 0 0 -.13333 0 671.787)"><path d="M2519.21 5038.41c-684.18 0-769.97-2.9-1038.67-15.16-268.14-12.23-451.27-54.82-611.513-117.09-165.66-64.38-306.148-150.52-446.203-290.57-140.051-140.05-226.191-280.55-290.57-446.21-62.273-160.24-104.86-343.37-117.098-611.51C2.898 3289.17 0 3203.38 0 2519.2c0-684.17 2.898-769.96 15.156-1038.66 12.239-268.14 54.825-451.27 117.098-611.509 64.379-165.66 150.519-306.152 290.57-446.211 140.055-140.05 280.543-226.191 446.203-290.57C1029.27 69.98 1212.4 27.39 1480.54 15.16 1749.24 2.902 1835.03 0 2519.21 0c684.17 0 769.96 2.902 1038.66 15.16 268.14 12.23 451.27 54.82 611.51 117.09 165.66 64.379 306.15 150.52 446.21 290.57 140.05 140.059 226.19 280.551 290.57 446.211 62.27 160.239 104.86 343.369 117.09 611.509 12.26 268.7 15.16 354.49 15.16 1038.66 0 684.18-2.9 769.97-15.16 1038.67-12.23 268.14-54.82 451.27-117.09 611.51-64.38 165.66-150.52 306.16-290.57 446.21-140.06 140.05-280.55 226.19-446.21 290.57-160.24 62.27-343.37 104.86-611.51 117.09-268.7 12.26-354.49 15.16-1038.66 15.16zm0-453.91c672.65 0 752.33-2.57 1017.97-14.69 245.62-11.2 379.01-52.24 467.78-86.74 117.59-45.7 201.51-100.29 289.66-188.44 88.16-88.16 142.75-172.08 188.45-289.67 34.5-88.77 75.54-222.16 86.74-467.78 12.12-265.64 14.69-345.32 14.69-1017.98 0-672.65-2.57-752.33-14.69-1017.97-11.2-245.62-52.24-379.01-86.74-467.78-45.7-117.591-100.29-201.509-188.45-289.661-88.15-88.16-172.07-142.75-289.66-188.449-88.77-34.5-222.16-75.539-467.78-86.738-265.6-12.122-345.27-14.692-1017.97-14.692-672.71 0-752.37 2.57-1017.98 14.692-245.62 11.199-379.01 52.238-467.78 86.738-117.591 45.699-201.509 100.289-289.661 188.449-88.152 88.152-142.75 172.07-188.449 289.661-34.5 88.77-75.535 222.16-86.742 467.78-12.121 265.64-14.688 345.32-14.688 1017.97 0 672.66 2.567 752.34 14.688 1017.98 11.207 245.62 52.242 379.01 86.742 467.78 45.699 117.59 100.293 201.51 188.445 289.66 88.156 88.16 172.074 142.75 289.665 188.45 88.77 34.5 222.16 75.54 467.78 86.74 265.64 12.12 345.32 14.69 1017.98 14.69"></path><path d="M2519.21 1679.47c-463.78 0-839.74 375.96-839.74 839.73 0 463.78 375.96 839.74 839.74 839.74 463.77 0 839.73-375.96 839.73-839.74 0-463.77-375.96-839.73-839.73-839.73zm0 2133.38c-714.47 0-1293.65-579.18-1293.65-1293.65 0-714.46 579.18-1293.64 1293.65-1293.64 714.46 0 1293.64 579.18 1293.64 1293.64 0 714.47-579.18 1293.65-1293.64 1293.65M4166.27 3863.96c0-166.96-135.35-302.3-302.31-302.3-166.95 0-302.3 135.34-302.3 302.3s135.35 302.31 302.3 302.31c166.96 0 302.31-135.35 302.31-302.31"></path></g></symbol><symbol viewbox="-27.7 455.1 337.2 791.1" id="icon-left" xmlns="http://www.w3.org/2000/svg"><path fill="inherit" d="M274.8 1246.2c-9.5 0-19.8-4-27.7-14.3l-262.9-350c-7.9-9.5-11.9-22.2-11.9-31.7 0-11.9 4-22.2 11.9-31.7l262.9-350.1c11.9-14.3 31.7-17.4 47.5-7.9 15.8 9.5 17.4 31.7 7.9 45.9L42.8 851l259.8 342.1c11.9 14.3 7.9 35.6-7.9 45.9-6.4 5.6-11.9 7.2-19.9 7.2"></path></symbol><symbol viewbox="0 0 18 18" id="icon-link" xmlns="http://www.w3.org/2000/svg"><g opacity=".4"><path d="M10.546 13.732l.623-.623a.957.957 0 0 0 .121-.137c.263-.273.48-.582.65-.905a4.44 4.44 0 0 0 .46-2.733 3.766 3.766 0 0 0-.158-.692 3.61 3.61 0 0 0-.244-.604 4.355 4.355 0 0 0-.877-1.245 4.35 4.35 0 0 0-1.245-.876l-1.14 1.14c-.08.08-.146.163-.204.256a2.735 2.735 0 0 1 2.07 2.07c.044.21.066.426.06.644a2.601 2.601 0 0 1-.765 1.81l-.69.689-.513.513-.485.485-1.237 1.237c-1.037 1.037-2.737 1.024-3.79-.029-1.052-1.052-1.064-2.753-.028-3.789L4.39 9.706a5.663 5.663 0 0 1-.208-2.338L1.881 9.67c-1.73 1.73-1.709 4.56.048 6.316 1.757 1.757 4.586 1.778 6.316.048l2.302-2.302z"></path><path d="M7.339 7.802a2.54 2.54 0 0 1 .1-.668c.114-.42.339-.814.665-1.14l.693-.694.51-.51.48-.48 1.242-1.241c1.036-1.036 2.736-1.024 3.789.029 1.052 1.052 1.064 2.753.029 3.789l-1.241 1.24c.233.76.302 1.556.211 2.335l2.303-2.303c1.73-1.73 1.708-4.558-.049-6.315C14.314.087 11.485.066 9.756 1.796L7.453 4.098l-.623.623a.934.934 0 0 0-.121.138 3.904 3.904 0 0 0-.645.9 4.39 4.39 0 0 0-.46 2.733c.028.244.08.472.153.696.065.206.142.41.245.604.209.452.503.87.877 1.244.373.374.791.668 1.244.878l1.14-1.141a1.38 1.38 0 0 0 .204-.256 2.68 2.68 0 0 1-1.335-.734 2.685 2.685 0 0 1-.793-1.98z"></path></g></symbol><symbol viewbox="0 0 16 16" id="icon-linkedin" xmlns="http://www.w3.org/2000/svg"><path d="M.2 15.876h3.394V5.222H.2v10.654zM1.997 0C.8 0 0 .836 0 1.88s.8 1.88 1.997 1.88 1.997-.836 1.997-1.88C3.794.836 2.994 0 1.997 0zm9.985 4.804c-1.798 0-2.596 1.045-2.996 1.88V5.222H5.392c.2 1.045 0 10.862 0 10.862h3.395V9.818c0-.21 0-.627.2-.836.2-.626.798-1.253 1.796-1.253 1.2 0 1.798 1.04 1.798 2.5v5.64h3.4V9.82c0-3.342-1.79-5.014-3.99-5.014z"></path></symbol><symbol viewbox="0 0 35.4 51" id="icon-map-marker" xmlns="http://www.w3.org/2000/svg"><path d="M18 51.733c11.8-15.9 17.7-27.1 17.7-33.5 0-9.7-7.9-17.5-17.7-17.5S.3 8.533.3 18.233c0 6.4 5.9 17.6 17.7 33.5z"></path><circle r="8" cy="18" cx="18" fill="#fff"></circle></symbol><symbol viewbox="-375 489.5 37.2 30.3" id="icon-menu" xmlns="http://www.w3.org/2000/svg"><title>menu</title>
<path d="M-367 489.5h29.1v3.8H-367zm-8 0h4.4v3.8h-4.4zm8 12.8h29.1v3.8H-367zm-8 0h4.4v3.8h-4.4zm8 13.7h29.1v3.8H-367zm-8 0h4.4v3.8h-4.4z"></path></symbol><symbol viewbox="0 0 179 96" id="icon-more" xmlns="http://www.w3.org/2000/svg"><title>more-arrow</title>
<path d="M178.86 47.677L129.776 0v34.313H0v26.625h116.296v.103h13.48v34.31l49.084-47.67"></path></symbol><symbol viewbox="0 0 50.062 37.479" id="icon-newsletter_signup" xmlns="http://www.w3.org/2000/svg"><path d="M25.085 21.866L.082 3.114A3.114 3.114 0 0 1 3.207-.012H46.96a3.113 3.113 0 0 1 3.126 3.126l-25 18.752zm0 5.613L50.087 8.726v25.64a3.113 3.113 0 0 1-3.125 3.125H3.208a3.113 3.113 0 0 1-3.125-3.125V8.727L25.085 27.48z" class="aushape-1"></path></symbol><symbol viewbox="0 0 832 512" id="icon-norgie-down" xmlns="http://www.w3.org/2000/svg"><path d="M15.244 98.497L379.433 495.43c20.249 22.24 53.137 22.23 73.373-.021.51-.608.71-1.47 1.25-2.077L817.152 98.259c20.233-22.224 20.223-58.326-.028-80.54-.202-.1-.531-.202-.735-.404C807.065 6.732 793.993-.005 779.353 0L52.923.208C38.073.212 24.903 7.286 15.43 18.18l-.2-.227c-20.314 22.325-20.304 58.33.023 80.543h-.008z"></path></symbol><symbol viewbox="0 0 512 832.328" id="icon-norgie-right" xmlns="http://www.w3.org/2000/svg"><path d="M98.278 817.088l397.038-364.076c22.245-20.243 22.245-53.13 0-73.373-.608-.51-1.47-.71-2.077-1.25L98.27 15.18c-22.218-20.24-58.32-20.24-80.54.005-.1.202-.202.53-.404.734C6.74 25.24 0 38.31 0 52.95v726.43c0 14.85 7.07 28.022 17.963 37.5l-.228.2c22.32 20.32 58.324 20.32 80.543 0z"></path></symbol><symbol viewbox="0 0 47.3 34.3" id="icon-opentable" xmlns="http://www.w3.org/2000/svg"><path d="M30.1 0C20.7 0 13 7.7 13 17.2s7.7 17.2 17.2 17.2 17.2-7.7 17.2-17.2C47.3 7.7 39.6 0 30.1 0zm0 21.5c-2.4 0-4.3-1.9-4.3-4.3s1.9-4.3 4.3-4.3 4.3 1.9 4.3 4.3c0 2.3-1.9 4.3-4.3 4.3zM0 17.2c0 2.4 1.9 4.3 4.3 4.3s4.3-1.9 4.3-4.3-1.9-4.3-4.3-4.3S0 14.8 0 17.2"></path></symbol><symbol viewbox="0 0 12 12" id="icon-pencil" xmlns="http://www.w3.org/2000/svg"><path d="M1.3 8.4c0 .1 0 .1 0 0L0 11.6c0 .1 0 .2.1.3 0 .1.1.1.1.1h.1l3.1-1.2s.1 0 .1-.1l6.2-6.2-2.2-2.3-6.2 6.2zm10.5-7L10.6.2c-.3-.3-.8-.3-1.1 0L8.2 1.5l2.2 2.2 1.3-1.3c.4-.2.4-.7.1-1z"></path></symbol><symbol viewbox="0 0 60.7 93.3" id="icon-pin" xmlns="http://www.w3.org/2000/svg"><path d="M57.2 34.6c0 4.8-1.3 9.3-3.5 13.2L31.8 87.5c-.3.5-.9.8-1.5.8-.7 0-1.2-.4-1.5-.8L6.9 47.7c-2.2-3.8-3.5-8.4-3.5-13.2 0-14.8 12-26.9 26.9-26.9 14.9.1 26.9 12.1 26.9 27zm-16.8 0c0-5.6-4.5-10.1-10.1-10.1S20.2 29 20.2 34.6s4.5 10.1 10.1 10.1 10.1-4.5 10.1-10.1z" xmlns="http://www.w3.org/2000/svg"></path></symbol><symbol viewbox="-285 377 40 40" id="icon-pinterest" xmlns="http://www.w3.org/2000/svg"><path d="M-265 377.1c-10.9 0-19.7 8.9-19.7 19.8 0 8.1 4.9 15 11.8 18.1-.1-1.4 0-3 .3-4.5.4-1.6 2.5-10.8 2.5-10.8s-.6-1.3-.6-3.1c0-2.9 1.7-5.1 3.8-5.1 1.8 0 2.7 1.3 2.7 3 0 1.8-1.2 4.5-1.7 7-.5 2.1 1 3.8 3.1 3.8 3.7 0 6.3-4.8 6.3-10.5 0-4.3-2.9-7.6-8.2-7.6-6 0-9.7 4.5-9.7 9.5 0 1.7.5 2.9 1.3 3.9.4.4.4.6.3 1.1l-.4 1.6c-.1.5-.5.7-1 .5-2.8-1.1-4-4.1-4-7.5 0-5.6 4.7-12.3 14.1-12.3 7.5 0 12.5 5.5 12.5 11.3 0 7.7-4.3 13.5-10.7 13.5-2.1 0-4.1-1.2-4.8-2.5 0 0-1.1 4.5-1.4 5.4-.4 1.5-1.2 3-2 4.2 1.8.5 3.7.8 5.6.8 10.9 0 19.7-8.8 19.7-19.7 0-11-8.9-19.9-19.8-19.9z"></path></symbol><symbol viewbox="-230 372 50 50" id="icon-play" xmlns="http://www.w3.org/2000/svg"><path fill="#999" d="M-214 376l25.6 21.1L-214 418v-42z"></path></symbol><symbol viewbox="0 0 17 17" id="icon-rec" xmlns="http://www.w3.org/2000/svg"><path d="M7.544.405l2.305 4.64 5.15.743L11.27 9.4l.88 5.1-4.61-2.407-4.6 2.407.88-5.1L.087 5.79l5.153-.744L7.545.404z"></path></symbol><symbol viewbox="0 0 450 386" id="icon-refresh" xmlns="http://www.w3.org/2000/svg"><path d="M352.629 288.14l96-111.9h-64.7c-2.3-27.9-10.5-54-23.5-77.3-27.4-49.2-75.8-85.1-133-95.6-.7-.1-1.5-.3-2.2-.4-.5-.1-.9-.2-1.4-.2-10.1-1.7-20.6-2.6-31.2-2.6h-.4c-90.9.2-167 63.6-186.7 148.6v.1c-.3 1.1-.5 2.2-.7 3.3-.1.5-.2.9-.3 1.4-.1.7-.3 1.4-.4 2.1-.2.9-.3 1.7-.5 2.6-.1.4-.1.7-.2 1.1l-.6 3.6v.2c-1 6.3-1.6 12.7-1.9 19.1v.8c-.1 1.4-.1 2.7-.2 4.1 0 1.6-.1 3.3-.1 5 0 1.7 0 3.3.1 5 0 1.4.1 2.7.2 4.1v.9c.3 6.5 1 12.9 1.9 19.1v.2l.6 3.6c.1.4.1.7.2 1.1.2.9.3 1.8.5 2.6.1.7.3 1.4.4 2.1.1.5.2 1 .3 1.4.2 1.1.5 2.2.7 3.2v.1c19.7 85 96.1 148.4 187.1 148.6 42.9-.1 83.1-14.2 116.9-40.7l7.5-5.9-43.2-46.2-6.2 4.6c-22.1 16.3-47.5 24.2-75 24.2-70.6 0-128-57-128-128s57.4-128 128-128c66.4 0 122.8 46.6 129.5 112h-73.5l104 112z" xmlns:bx="https://boxy-svg.com" bx:origin="0.5 0.5"></path></symbol><symbol viewbox="-27.7 455.1 337.2 791.1" id="icon-right" xmlns="http://www.w3.org/2000/svg"><path fill="inherit" d="M6.9 455.1c9.5 0 19.8 4 27.7 14.3l262.9 350.1c7.9 9.5 11.9 22.2 11.9 31.7 0 11.9-4 22.2-11.9 31.7l-262.8 350c-11.9 14.3-31.7 17.4-47.5 7.9-15.8-9.5-17.4-31.7-7.9-45.9L239 850.3-20.8 508.2c-11.9-14.3-7.9-35.6 7.9-45.9 6.4-5.6 11.9-7.2 19.8-7.2"></path></symbol><symbol viewbox="0 0 1000 1000" preserveaspectratio="xMinYMin meet" id="icon-rss" xmlns="http://www.w3.org/2000/svg"><path d="M0 866q0-55 39-94t94-39 94 39 39 94q0 56-39 94.5T133 999t-94-39-39-94zm0-335V340q179 0 331 88.5T571.5 669t88.5 331H468q0-194-137-331Q193 531 0 531zm0-339V0q203 0 388 79.5T707 293t213.5 319 79.5 388H808q0-164-64-314T571.5 428t-258-172T0 192z"></path></symbol><symbol viewbox="373.3 133.3 533.3 533.3" id="icon-search" xmlns="http://www.w3.org/2000/svg"><path d="M754.7 468.7l-22.3-22.3c24.3-33.3 37.5-73.4 37.7-114.7 0-109.5-88.8-198.3-198.3-198.3s-198.3 88.8-198.3 198.3S462.1 530 571.7 530c41.2-.2 81.3-13.4 114.7-37.7l22.3 22.3 152.7 152 45.3-45.3-152-152.6zm-183 0c-75.8 0-137.3-61.5-137.3-137.3S495.8 194 571.7 194 709 255.5 709 331.3c.2 75.7-61 137.1-136.7 137.3-.2.1-.4.1-.6.1z"></path></symbol><symbol viewbox="206 29.9 642.1 681.3" id="icon-settings" xmlns="http://www.w3.org/2000/svg"><path d="M843 467.2c4.8 3.2 6.3 9.5 4 15-13.5 41.2-36.4 79.2-64.2 111.7-4 4.8-9.5 6.3-15 4l-81.6-28.5c-20.6 16.6-43.6 30.1-67.3 39.6l-16.6 84.7c-.8 5.5-5.5 10.3-11.1 11.1-21.4 4-42.8 6.3-64.2 6.3-22.2 0-43.6-2.4-64.2-6.3-5.5-.8-10.3-5.5-11.1-11.1L435.2 609c-24.6-9.5-48.3-23-67.3-39.6l-81.6 28.5c-5.5 2.4-11.1.8-15-4-28.5-32.5-51.5-70.5-64.2-111.7-2.4-5.5-.8-11.9 4-15l64.9-57c-2.4-12.7-3.2-26.1-3.2-39.6s.8-26.9 3.2-39.6l-65-57c-4.8-3.2-6.3-9.5-4-15 13.5-41.2 36.4-79.2 64.2-111.7 4-4.8 9.5-6.3 15-4l81.6 28.5c19.8-16.6 43.6-30.1 67.3-39.6l16.6-84.7c.8-5.5 5.5-10.3 11.1-11.1 42.8-8.7 86.3-8.7 129.1 0 5.5.8 10.3 5.5 11.1 11.1l15 85.5c24.6 9.5 47.5 23 67.3 39.6l81.6-28.5c5.5-2.4 11.1-.8 15 4 28.5 32.5 51.5 70.5 64.2 111.7 2.4 5.5.8 11.9-4 15l-65.7 57c2.4 12.7 3.2 26.1 3.2 39.6s-.8 26.9-3.2 39.6l66.6 56.2zm-190-95.8c0-69.7-57.8-127.5-127.5-127.5-70.5 0-127.5 57-127.5 127.5s57 127.5 127.5 127.5S653 441.9 653 371.4z"></path></symbol><symbol viewbox="0 0 16 16" id="icon-snapchat" xmlns="http://www.w3.org/2000/svg"><path d="M8.155.48c.662 0 2.903.185 3.96 2.552.354.797.27 2.15.2 3.237l-.002.04c-.008.12-.015.23-.02.34.05.03.135.06.268.06.2-.01.44-.08.69-.2.11-.06.23-.07.31-.07.12 0 .24.02.34.06.3.1.49.32.49.56.01.3-.26.56-.81.78-.06.02-.14.05-.23.08-.3.09-.76.24-.89.54-.06.15-.04.35.08.58l.01.01c.04.09 1.02 2.32 3.2 2.68.17.03.29.18.28.34 0 .05-.01.1-.03.15-.16.38-.85.66-2.1.85-.04.06-.08.25-.11.38-.02.12-.05.24-.09.37-.05.18-.18.27-.37.27h-.02c-.09 0-.21-.02-.36-.05-.24-.05-.51-.09-.85-.09-.2 0-.4.01-.61.05-.4.07-.75.31-1.15.59-.57.4-1.22.86-2.2.86-.04 0-.08-.01-.12-.01h-.1c-.98 0-1.62-.45-2.19-.86-.4-.28-.74-.52-1.14-.59-.21-.03-.42-.05-.62-.05-.36 0-.64.06-.85.1-.14.03-.26.05-.36.05-.25 0-.35-.15-.39-.28-.04-.13-.06-.26-.09-.38s-.07-.33-.11-.38C.89 12.9.2 12.62.04 12.23a.413.413 0 0 1-.036-.15.332.332 0 0 1 .28-.34c2.18-.36 3.16-2.59 3.2-2.684l.01-.02c.12-.23.15-.43.08-.58-.13-.29-.59-.44-.89-.54-.08-.02-.16-.05-.23-.08-.74-.29-.84-.62-.8-.85.06-.32.45-.53.78-.53.097 0 .18.02.256.05.28.13.527.2.737.2a.63.63 0 0 0 .31-.07l-.03-.38c-.065-1.086-.15-2.438.205-3.23C4.94.67 7.175.49 7.835.49l.28-.01h.04z"></path></symbol><symbol viewbox="0 0 17 17" id="icon-star" xmlns="http://www.w3.org/2000/svg"><path d="M7.544.405l2.305 4.64 5.15.743L11.27 9.4l.88 5.1-4.61-2.407-4.6 2.407.88-5.1L.087 5.79l5.153-.744L7.545.404z"></path></symbol><symbol viewbox="19.3 54.3 26.9 33.7" id="icon-thumb-down" xmlns="http://www.w3.org/2000/svg"><title>no</title>
<path d="M19.3 84.4c0-4.8 0-9.4.1-14 0-.4 1-1 1.6-1.2 4.2-1.1 7.7-3.2 9.6-7.3.7-1.6.9-3.4 1.5-5 .4-.9 1.2-1.7 1.8-2.5.7.8 2 1.6 2.1 2.5.2 2.2 0 4.5-.2 6.8-.1.9-.4 1.8-.6 3h5.1c1.2 0 2.4 0 3.5.2 1.9.3 2.4 1.3 2.2 3.2-.1 1.2.1 2.4.1 3.6 0 1 0 1.9-.1 2.9-.1 1.1 0 2.2-.3 3.1-1 2.6-2.1 5.2-3.4 7.6-.3.6-1.8.7-2.7.7-2.4.1-4.8.2-7.2 0-1.4-.1-2.9-.5-4-1.3-2.2-1.7-4.4-2.3-7.1-2.1-.6-.1-1.2-.2-2-.2z"></path></symbol><symbol viewbox="19.3 54.3 26.9 33.7" id="icon-thumb-up" xmlns="http://www.w3.org/2000/svg"><title>yes</title>
<path d="M19.3 84.4c0-4.8 0-9.4.1-14 0-.4 1-1 1.6-1.2 4.2-1.1 7.7-3.2 9.6-7.3.7-1.6.9-3.4 1.5-5 .4-.9 1.2-1.7 1.8-2.5.7.8 2 1.6 2.1 2.5.2 2.2 0 4.5-.2 6.8-.1.9-.4 1.8-.6 3h5.1c1.2 0 2.4 0 3.5.2 1.9.3 2.4 1.3 2.2 3.2-.1 1.2.1 2.4.1 3.6 0 1 0 1.9-.1 2.9-.1 1.1 0 2.2-.3 3.1-1 2.6-2.1 5.2-3.4 7.6-.3.6-1.8.7-2.7.7-2.4.1-4.8.2-7.2 0-1.4-.1-2.9-.5-4-1.3-2.2-1.7-4.4-2.3-7.1-2.1-.6-.1-1.2-.2-2-.2z"></path></symbol><symbol viewbox="0 0 60.7 93.3" id="icon-topics" xmlns="http://www.w3.org/2000/svg"><g xmlns="http://www.w3.org/2000/svg"><path d="M2.5 21.5h55.2v11.8H2.5zM2.5 42.1h55.2v11.8H2.5zM2.5 64.3h55.2v11.8H2.5z"></path></g></symbol><symbol viewbox="0 0 87 60" id="icon-trending" xmlns="http://www.w3.org/2000/svg"><path d="M1.906 46.826c2.213 1.787 5.466 1.46 7.262-.743v-.006l5.26-6.45 8.378 11.286a5.171 5.171 0 0 0 4.827 2.035 5.128 5.128 0 0 0 4.124-3.215l7.96-20.208L51.26 56.577a5.155 5.155 0 0 0 4.754 3.13c.097 0 .19 0 .286-.007a5.172 5.172 0 0 0 4.66-3.667l10.98-36.787 4.854 9.902c1.234 2.552 4.33 3.613 6.89 2.37 2.56-1.234 3.636-4.314 2.386-6.86L75.42 2.888a5.15 5.15 0 0 0-5.067-2.87 5.135 5.135 0 0 0-4.52 3.653L55.146 39.42 44.28 13.93a5.142 5.142 0 0 0-4.827-3.127 5.157 5.157 0 0 0-4.73 3.263L25.56 37.343l-6.79-9.148a5.197 5.197 0 0 0-4.033-2.08 5.139 5.139 0 0 0-4.124 1.897L1.153 39.6a5.125 5.125 0 0 0 .753 7.226" fill-rule="evenodd"></path></symbol><symbol viewbox="0 0 23.62 41.098" id="icon-tumblr" xmlns="http://www.w3.org/2000/svg"><path d="M21.643 32.826c-.764.364-2.226.682-3.316.71-3.29.088-3.927-2.31-3.955-4.052V16.69h8.252v-6.22h-8.222V0h-6.02c-.1 0-.272.087-.296.307C7.734 3.512 6.234 9.135 0 11.382v5.31h4.16V30.12c0 4.595 3.39 11.126 12.343 10.974 3.02-.053 6.375-1.318 7.117-2.408l-1.977-5.86z"></path></symbol><symbol viewbox="0 0 44.71 36.327" id="icon-twitter" xmlns="http://www.w3.org/2000/svg"><path d="M44.71 4.295c-1.656.724-3.415 1.242-5.278 1.45A9.146 9.146 0 0 0 43.468.673a18.75 18.75 0 0 1-5.796 2.225C35.965 1.138 33.584 0 30.945 0a9.145 9.145 0 0 0-9.16 9.16c0 .724.052 1.448.208 2.12-7.607-.413-14.335-3.88-18.888-9.417-.777 1.345-1.242 2.742-1.242 4.45 0 3.157 1.604 5.95 4.088 7.607a9.376 9.376 0 0 1-4.14-1.138v.103c0 4.45 3.16 8.176 7.35 9.004-.77.2-1.6.31-2.43.31-.57 0-1.14-.06-1.71-.16 1.14 3.62 4.56 6.31 8.54 6.36-3.1 2.48-7.09 4.34-11.38 4.34-.72 0-1.45-.05-2.17-.16 4.04 2.59 8.9 3.72 14.08 3.72 16.87 0 26.08-13.97 26.08-26.08V9.05c1.76-1.294 3.32-2.9 4.56-4.76"></path></symbol><symbol viewbox="-235.8 423.2 35.7 21.3" id="icon-up" xmlns="http://www.w3.org/2000/svg"><path fill="none" d="M-200.5 444.2L-218 424l-17.5 20.2"></path></symbol><symbol viewbox="373.3 133.3 533.3 533.3" id="icon-user" xmlns="http://www.w3.org/2000/svg"><path d="M640 400c73.6 0 133.3-59.7 133.3-133.3S713.6 133.3 640 133.3 506.7 193 506.7 266.7 566.4 400 640 400zm0 66.7c-89 0-266.7 44.7-266.7 133.3v66.7h533.3V600c.1-88.7-177.6-133.3-266.6-133.3z"></path></symbol><symbol viewbox="0 0 1146 1000" id="icon-vimeo" xmlns="http://www.w3.org/2000/svg"><path d="M0 272q55-65 110-116t95.5-77.5 72.5-43T326 14l17-4q12-2 24-2 19 0 35 6 26 10 42.5 34.5t29 55 21.5 72 15 77.5 13.5 79.5T538 403q32 125 51.5 177.5T631 633q24 0 66.5-55.5T791 426q26-48 26-91 0-13-2-23-9-52-51-65-11-4-24-4-35 0-83 26 22-130 134-209Q876 0 965 0q12 0 24 1 102 8 139 90 18 38 18 88 0 29-6 61-18 102-69.5 208t-113 187.5-132.5 155-123.5 117T611 976q-42 24-78.5 24T463 979t-56-48-38-57q-18-38-97.5-298.5T175 295q-1-2-4-4t-13.5-4.5-24 0-36.5 14T47 333z"></path></symbol><symbol viewbox="0 0 86.965 87.642" id="icon-whatsapp" xmlns="http://www.w3.org/2000/svg"><path fill-rule="evenodd" clip-rule="evenodd" d="M44.038 13.007c-16.58 0-30.02 13.44-30.02 30.02a29.883 29.883 0 0 0 4.307 15.503l-5.418 16.106 16.62-5.32a29.915 29.915 0 0 0 14.512 3.733c16.58 0 30.02-13.45 30.02-30.03C74.06 26.44 60.61 13 44.03 13zm0 55.013a24.85 24.85 0 0 1-13.75-4.132l-9.604 3.074 3.122-9.28a24.858 24.858 0 0 1-4.76-14.653c0-13.79 11.212-25 24.993-25 13.78 0 24.99 11.21 24.99 24.99 0 13.78-11.22 24.99-25 24.99zm14.075-18.17c-.753-.412-4.45-2.407-5.143-2.69-.693-.28-1.2-.427-1.74.32s-2.072 2.418-2.538 2.913c-.467.495-.916.54-1.668.128-.752-.41-3.19-1.31-6.02-4.03-2.202-2.11-3.646-4.68-4.065-5.46-.42-.78-.01-1.18.39-1.55.35-.33.8-.86 1.2-1.3.4-.43.54-.74.81-1.25.27-.5.16-.95-.02-1.34s-1.57-4.22-2.15-5.77c-.58-1.56-1.23-1.32-1.68-1.34-.45-.01-.96-.1-1.47-.12-.51-.02-1.35.14-2.08.89-.73.74-2.78 2.52-2.92 6.29-.14 3.77 2.47 7.52 2.83 8.04.36.53 4.98 8.7 12.66 12.06 7.67 3.36 7.71 2.34 9.12 2.26 1.41-.07 4.6-1.68 5.31-3.45.7-1.76.76-3.3.58-3.62-.18-.32-.68-.54-1.43-.95z"></path></symbol><symbol viewbox="130.35156 177.43359 300 300" overflow="visible" id="icon-yahoo" xmlns="http://www.w3.org/2000/svg"><path d="M420.926 272.27c-5.2.514-26.85 5.365-34.13 6.925-7.79 2.073-78.983 57.075-83.66 70.58-1.036 4.674-1.556 11.866-1.556 18.624l-.52 10.91c-.002 7.79 2.162 20.35 3.198 27.1 4.68 1.04 38.555.13 44.79 1.17l-.768 13.97c-6.09-.45-49.106-.34-73.68-.34-12.475 0-52.576 1.37-64.897 1l2.33-13.29c6.755-.53 34.728 1.2 40.878-5.29 3.06-3.22 2.09-6.67 2.09-25.38v-8.83c0-4.16 0-11.96-1.04-19.24-2.59-7.8-65.3-86.09-81.41-98.56-4.68-1.56-33.99-4.49-41.26-6.05l-.36-11.97c3.63-1.82 36.22.44 67.85-.73 20.79-.77 68.22 0 74.07.7l-1.5 10.55c-6.23 1.56-36.26 2.14-44.06 4.21 20.27 30.14 52.31 68.94 62.71 84.01 5.72-8.31 55.96-42.87 57.51-54.82-7.79-1.57-33.6-5.28-37.76-5.28l-2.47-13.61c7.08-1.11 44.28 0 62.78 0 15.96 0 50.07 0 59.76.79l-8.86 12.81"></path></symbol><symbol viewbox="0 0 462 325" id="icon-youtube" xmlns="http://www.w3.org/2000/svg"><path d="M234.28 1.691c-53.492 0-132.53 3.24-156.188 4.031C52.396 8.02 42.884 9.366 28.811 21.41 7.368 40.48 2.28 77.954 2.28 135.285v54.562c0 65.439 8.69 98.684 23 110.844 16.517 14.17 27.407 15.302 38.406 17 4.27.646 34.49 6 168.594 6 83.626 0 155.507-3.95 162.937-4.906 11.945-1.508 29.104-3.696 42.063-18.094 19.183-21.803 23-57.999 23-110.437V126.69c0-33.943-1.891-81.916-23-102-15.991-13.536-21.848-17.367-54.938-19.031-9.358-.462-91.02-3.969-148.062-3.969zm-49.5 97l123.5 63.75-123.5 64.25v-128z"></path></symbol></svg>

      <div class="l-root l-reskin">
    <div class="l-header">
      
      
<div class="chorus-emc__content" data-emc-slug="UnisonCustomNavCell" data-emc-bucket="55::">
    <header class="c-global-header " data-cid="site/global_header-1649516448_2088_358058" role="banner" data-analytics-placement="navigation" data-cdata='{"nav_items_limit":0}'>
  <div class="l-wrapper">
    <div class="c-global-header__logo ">
      <a href="/" id="chorus-brand" data-analytics-link="home">
        
          <span class="sr-only">Mile High Report homepage</span>
          <span class="c-global-header__logo-large" aria-hidden="true" tabindex="-1">
            <img src="https://cdn.vox-cdn.com/uploads/blog/sbnu_logo/55/large_Mile_High_Report_Full.162116.png" class="">

          </span>
        
        
          <span class="c-global-header__logo-small c-global-header__logo-lockup">
            <img src="https://cdn.vox-cdn.com/uploads/blog/sbnu_logo/55/large_Mile_High_Report_Full.162116.png" class="">

            <span class="c-global-header__logo-network ">
              <svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewbox="0 0 1000 137.7" enable-background="new 0 0 1000 137.7" xml:space="preserve">
<title>Horizontal - White</title>
<path fill="#FFFFFF" d="M245.3,68.1c11.5,0,20.8-9.1,21.1-20.6c0-7.2,0-12.7,0-12.7C266.5,13.9,253,0,233.7,0h-95v137.7H234
	c16.3,0,32.5-12.5,32.5-33.7V89.2C266.5,77.5,257,68.1,245.3,68.1z M216,98.6c0,1.7-1.3,3-3,3h-23.8v-15h23.6c1.8,0,3.2,1.5,3.2,3.2
	c0,0,0,0,0,0V98.6z M216,46.2c0,1.8-1.5,3.3-3.3,3.3h-23.5V36.1h23.5c1.9,0,3.4,1.5,3.4,3.4L216,46.2z"></path>
<path fill="#FFFFFF" d="M127.7,42.8v-9.1c0-6.6-1.8-13-5.1-18.7l0.1-0.2C117,6,107.4,0.5,96.9,0h-0.1c-0.4,0-0.8,0-1.2,0H32.3
	C14.5,0,0,14.5,0,32.3v18.7l0,0v8.8c0,14.9,12,26.9,26.9,26.9c0,0,0,0,0,0h46.9c1.9,0,3.4,1.5,3.4,3.5l0,0v8c0,1.9-1.6,3.5-3.5,3.5
	H50.5v-6.6H0v10.2c0,6.2,1.8,12.3,5.1,17.5l-0.1,0.2c5.6,8.8,15.3,14.4,25.7,14.8h0.1c0.4,0,0.8,0,1.2,0h63.3
	c17.8,0,32.3-14.4,32.3-32.3l0,0V86.8l0,0V76.4c0-14.9-12-26.9-26.9-26.9h0H53.9c-1.9,0-3.4-1.5-3.4-3.5l0,0v-6.5
	c0-1.9,1.6-3.5,3.5-3.5h23.4v6.7H127.7z"></path>
<rect x="674.1" fill="#FFFFFF" width="50.5" height="137.7"></rect>
<polygon fill="#FFFFFF" points="664.4,0 549.2,0 549.2,36.3 581.6,36.3 581.6,137.7 632,137.7 632,36.3 664.4,36.3 "></polygon>
<path fill="#FFFFFF" d="M830.5,0h-62.8c-17.8,0-32.3,14.5-32.3,32.3v73.1c0,17.8,14.5,32.3,32.3,32.3h62.8
	c17.8,0,32.3-14.5,32.3-32.3V32.3C862.8,14.5,848.4,0,830.5,0L830.5,0z M812.4,98.4c0,1.8-1.5,3.2-3.2,3.2h-20
	c-1.8,0-3.2-1.5-3.2-3.2v-59c0-1.8,1.5-3.2,3.2-3.2h20c1.8,0,3.2,1.5,3.2,3.2V98.4z"></path>
<path fill="#FFFFFF" d="M951,0v49.7L915.8,9.5c-5.1-6-12.6-9.5-20.5-9.5h-21.5v137.7h49V87.8l35.2,40.3c5.1,6,12.6,9.5,20.5,9.5
	h21.5V0H951z"></path>
<path fill="#FFFFFF" d="M354.7,0v49.7L319.4,9.5c-5.1-6-12.6-9.5-20.5-9.5h-21.5v137.7h49V87.8l35.2,40.3c5.1,6,12.6,9.5,20.5,9.5
	h21.5V0H354.7z"></path>
<path fill="#FFFFFF" d="M531.6,17.9C527.8,7.2,517.7,0,506.3,0h-70v36.3h10.5l-35.2,101.3h50.6l7.2-20.8H516l7.2,20.9h50L531.6,17.9
	z M492.6,49.6l10.8,31h-21.4L492.6,49.6z"></path>
</svg>
              <span class="c-global-header__logo-community">
                Mile High Report
              </span>
            </span>
          </span>
        
        
        
      </a>
      
        <span class="c-global-header__topic">a Denver Broncos community</span>
      
    </div>
    
      <h2 class="sr-only" id="global-header__social--label">Follow Mile High Report online:</h2>
      <ul class="c-global-header__social" aria-labelledby="global-header__social--label">
      
        <li><a href="https://www.twitter.com/MileHighReport" class="twitter">
          <svg role="img" class="p-svg-icon"><title>Follow Mile High Report on Twitter</title>
<use xlink:href="#icon-twitter"></use></svg>
          
        </a></li>
      
        <li><a href="http://www.facebook.com/MileHighReport" class="facebook">
          <svg role="img" class="p-svg-icon"><title>Follow Mile High Report on Facebook</title>
<use xlink:href="#icon-facebook"></use></svg>
          
        </a></li>
      
      </ul>
    
    
      <div class="c-global-header__actions">
    

    

    
      
      <div class="c-global-header__login logged_out_menu">
        <a class="c-global-header__login-icon" href="https://auth.voxmedia.com/login?community_id=55&amp;return_to=https%3A%2F%2Fwww.milehighreport.com%2F" data-return-to data-ui="icon"><svg role="img" class="c-global-header__login-svg"><use xlink:href="#icon-user"></use></svg>
          <span class="sr-only">Log in or sign up</span>
        </a>
        <ul class="c-global-header__login-menu" data-ui="menu">
          <li class="c-global-header__login-menu-item logged_out_item">
            <a href="https://auth.voxmedia.com/login?community_id=55&amp;return_to=https%3A%2F%2Fwww.milehighreport.com%2F" data-return-to data-analytics-link="login">Log In</a>
          </li>
          
            <li class="c-global-header__login-menu-item logged_out_item">
              <a href="https://auth.voxmedia.com/signup?community_id=55&amp;return_to=https%3A%2F%2Fwww.milehighreport.com%2F" data-return-to data-analytics-link="signup">Sign Up</a>
            </li>
          
        </ul>
      </div>
      
    
    
    
      <div class="c-global-header__search" aria-labelledby="global-header__search--label">
        <h2 class="sr-only" id="global-header__search--label">Site search</h2>
        <button type="submit" class="c-global-header__search-trigger">
          <span class="sr-only">Search</span>
          <svg role="img" class="c-global-header__login-svg" aria-hidden="true"><title>Search</title>
<use xlink:href="#icon-search"></use></svg>
        </button>
      </div>
    
    
      </div>
    
    
    <nav class="c-global-header__links" aria-labelledby="global-header__links--label">
      <h2 id="global-header__links--label" class="sr-only">Mile High Report main menu</h2>
      <ul>
        
          
          
          
            <li class="c-global-header__link " data-nav-item-id="fanposts">
              
              <a href="/fanposts">
              Fanposts
              
              </a>
              
              
            </li>
          
            <li class="c-global-header__link  hidden" data-nav-item-id="draftkings" data-nav-list-trigger="draftkings">
              
              <a href="https://sportsbook.draftkings.com/featured?category=live-in-game">
              DraftKings
              
                <span class="c-global-header__link-arrow"><svg role="img"><use xlink:href="#icon-norgie-down"></use></svg></span>
              
              </a>
              
              
            </li>
          
            <li class="c-global-header__link  hidden" data-nav-item-id="fanshots">
              
              <a href="fanshots">
              Fanshots
              
              </a>
              
              
            </li>
          
            <li class="c-global-header__link  hidden" data-nav-item-id="sections" data-nav-list-trigger="sections">
              
              <a href="/sections">
              Sections
              
                <span class="c-global-header__link-arrow"><svg role="img"><use xlink:href="#icon-norgie-down"></use></svg></span>
              
              </a>
              
              
            </li>
          
            <li class="c-global-header__link  hidden" data-nav-item-id="broncos" data-nav-list-trigger="broncos">
              
              <a href="http://www.sbnation.com/nfl/teams/denver-broncos">
              Broncos
              
                <span class="c-global-header__link-arrow"><svg role="img"><use xlink:href="#icon-norgie-down"></use></svg></span>
              
              </a>
              
              
            </li>
          
            <li class="c-global-header__link is-pinned" data-nav-item-id="shop">
              
              <a href="http://www.fanatics.com/NFL_Denver_Broncos/?partnerid=14104">
              Shop
              
              </a>
              
              
            </li>
          
            <li class="c-global-header__link  hidden" data-nav-item-id="about">
              
              <a href="/masthead">
              About
              
              </a>
              
              
            </li>
          
            <li class="c-global-header__link  hidden" data-nav-item-id="masthead">
              
              <a href="/masthead">
              Masthead
              
              </a>
              
              
            </li>
          
            <li class="c-global-header__link  hidden" data-nav-item-id="community-guidelines">
              
              <a href="/community-guidelines">
              Community Guidelines
              
              </a>
              
              
            </li>
          
            <li class="c-global-header__link  hidden" data-nav-item-id="odds">
              
              <a href="https://dknation.draftkings.com/nfl-odds-lines">
              Odds
              
              </a>
              
              
            </li>
          
            <li class="c-global-header__link  hidden" data-nav-item-id="fantasy-football">
              
              <a href="https://dknation.draftkings.com/daily-fantasy-football-dfs">
              Fantasy Football
              
              </a>
              
              
            </li>
          
        
        <li class="c-global-header__link-more " data-nav-list-trigger="more">
          <a class="c-global-header__label">
            More
            <span class="c-global-header__link-arrow"><svg role="img"><use xlink:href="#icon-norgie-down"></use></svg></span>
            <span class="c-global-header__link-hamburger"><svg role="img"><use xlink:href="#icon-hamburger"></use></svg></span>
          </a>
        </li>
      </ul>
    </nav>
    
      <div class="c-global-header__primary-community ">
        <a href="https://www.sbnation.com/blogs">
          All 300 communities <span class="c-global-header__primary-community-tag">on</span> 
          <svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewbox="0 0 1000 137.7" enable-background="new 0 0 1000 137.7" xml:space="preserve">
<title>Horizontal - White</title>
<path fill="#FFFFFF" d="M245.3,68.1c11.5,0,20.8-9.1,21.1-20.6c0-7.2,0-12.7,0-12.7C266.5,13.9,253,0,233.7,0h-95v137.7H234
	c16.3,0,32.5-12.5,32.5-33.7V89.2C266.5,77.5,257,68.1,245.3,68.1z M216,98.6c0,1.7-1.3,3-3,3h-23.8v-15h23.6c1.8,0,3.2,1.5,3.2,3.2
	c0,0,0,0,0,0V98.6z M216,46.2c0,1.8-1.5,3.3-3.3,3.3h-23.5V36.1h23.5c1.9,0,3.4,1.5,3.4,3.4L216,46.2z"></path>
<path fill="#FFFFFF" d="M127.7,42.8v-9.1c0-6.6-1.8-13-5.1-18.7l0.1-0.2C117,6,107.4,0.5,96.9,0h-0.1c-0.4,0-0.8,0-1.2,0H32.3
	C14.5,0,0,14.5,0,32.3v18.7l0,0v8.8c0,14.9,12,26.9,26.9,26.9c0,0,0,0,0,0h46.9c1.9,0,3.4,1.5,3.4,3.5l0,0v8c0,1.9-1.6,3.5-3.5,3.5
	H50.5v-6.6H0v10.2c0,6.2,1.8,12.3,5.1,17.5l-0.1,0.2c5.6,8.8,15.3,14.4,25.7,14.8h0.1c0.4,0,0.8,0,1.2,0h63.3
	c17.8,0,32.3-14.4,32.3-32.3l0,0V86.8l0,0V76.4c0-14.9-12-26.9-26.9-26.9h0H53.9c-1.9,0-3.4-1.5-3.4-3.5l0,0v-6.5
	c0-1.9,1.6-3.5,3.5-3.5h23.4v6.7H127.7z"></path>
<rect x="674.1" fill="#FFFFFF" width="50.5" height="137.7"></rect>
<polygon fill="#FFFFFF" points="664.4,0 549.2,0 549.2,36.3 581.6,36.3 581.6,137.7 632,137.7 632,36.3 664.4,36.3 "></polygon>
<path fill="#FFFFFF" d="M830.5,0h-62.8c-17.8,0-32.3,14.5-32.3,32.3v73.1c0,17.8,14.5,32.3,32.3,32.3h62.8
	c17.8,0,32.3-14.5,32.3-32.3V32.3C862.8,14.5,848.4,0,830.5,0L830.5,0z M812.4,98.4c0,1.8-1.5,3.2-3.2,3.2h-20
	c-1.8,0-3.2-1.5-3.2-3.2v-59c0-1.8,1.5-3.2,3.2-3.2h20c1.8,0,3.2,1.5,3.2,3.2V98.4z"></path>
<path fill="#FFFFFF" d="M951,0v49.7L915.8,9.5c-5.1-6-12.6-9.5-20.5-9.5h-21.5v137.7h49V87.8l35.2,40.3c5.1,6,12.6,9.5,20.5,9.5
	h21.5V0H951z"></path>
<path fill="#FFFFFF" d="M354.7,0v49.7L319.4,9.5c-5.1-6-12.6-9.5-20.5-9.5h-21.5v137.7h49V87.8l35.2,40.3c5.1,6,12.6,9.5,20.5,9.5
	h21.5V0H354.7z"></path>
<path fill="#FFFFFF" d="M531.6,17.9C527.8,7.2,517.7,0,506.3,0h-70v36.3h10.5l-35.2,101.3h50.6l7.2-20.8H516l7.2,20.9h50L531.6,17.9
	z M492.6,49.6l10.8,31h-21.4L492.6,49.6z"></path>
</svg>
        </a>
      </div>
    
    
      <div class="p-input-header c-global-header__search-menu" data-analytics-class="search">
  <form action="/search" method="GET" id="global_search_form" data-analytics-class="search">
    
    <input class="p-input-header__input" name="q" placeholder="Search">
    <input type="submit" class="p-input-header__link p-button" value="Search">
  </form>
</div>

    
    
      <div class="chorus-ad-placement chorus-ad-placement__site_sponsorship_logo">
  <div class="site_sponsorship_logo "></div>
  <div class="site_sponsorship_logo_mobile "></div>
</div>

    
  </div>
</header>
<section class="c-nav-list" data-cid="site/nav_list-1649516448_6481_358057" data-cdata='{"tab_id":"more"}'>
  <div class="c-nav-list__inner">
  
    <ul class="c-nav-list__main" data-nav-list-id="more">
      
        <li data-nav-item-id="fanposts">
        
          <a class="c-nav-list__label" href="/fanposts">
            Fanposts
            
          </a>
          
        

         
        </li>
      
        <li data-nav-item-id="draftkings" data-nav-list-id="draftkings">
        
          <a class="c-nav-list__label" href="https://sportsbook.draftkings.com/featured?category=live-in-game">
            DraftKings
            
              <span class="c-nav-list__arrow-down"><svg role="img"><use xlink:href="#icon-norgie-down"></use></svg></span>
            
          </a>
          
        

         
            
            
              <ul class="c-nav-list__sub-items">
                
                  
                    
                    <li class=" ">
                      
                        <a href="https://dksb.sng.link/As9kz/71h7?_dl=https%3A%2F%2Fsportsbook.draftkings.com%2Fgateway%3Fs%3D952727767%26wpcid%3D163241%26wpcn%3DNavBar%26wpsrc%3DVox%26wpcrid%3DNavBar&amp;pcid=163241&amp;pscn=NavigationBar&amp;pcrn=NavigationBar&amp;psn=Vox">
                          DraftKings Sportsbook
                        </a>
                      
                      
                    </li>
                    
                    <li class=" ">
                      
                        <a href="https://dkdfs.sng.link/Avkw3/kc7f?_dl=https%3A%2F%2Fwww.draftkings.com%2Fgateway%3Fs%3D826914429%26wpcid%3D163866%26wpcn%3DNavigationBar%26wpsrc%3DVox%26wpcrid%3DNavBar%26wpscn%3DNavigationBar%26wpsn%3DVox%26wpssn%3DSBNation&amp;pcid=163866&amp;pcrid=NavBar&amp;psn=Vox&amp;pssn=SBNation&amp;pcn=NavigationBar">
                          DraftKings Daily Fantasy Sports
                        </a>
                      
                      
                    </li>
                    
                  
                
                
              </ul>
            
          
        </li>
      
        <li data-nav-item-id="fanshots">
        
          <a class="c-nav-list__label" href="fanshots">
            Fanshots
            
          </a>
          
        

         
        </li>
      
        <li data-nav-item-id="sections" data-nav-list-id="sections">
        
          <a class="c-nav-list__label" href="/sections">
            Sections
            
              <span class="c-nav-list__arrow-down"><svg role="img"><use xlink:href="#icon-norgie-down"></use></svg></span>
            
          </a>
          
        

         
            
            
              <ul class="c-nav-list__sub-items has-columns">
                
                  
                    <div class="c-nav-list__col">
                  
                    
                    <li class=" ">
                      
                        <a href="https://www.milehighreport.com/broncos-news">
                          Broncos News
                        </a>
                      
                      
                    </li>
                    
                    <li class=" ">
                      
                        <a href="https://www.milehighreport.com/broncos-schedule">
                          Broncos Schedule
                        </a>
                      
                      
                    </li>
                    
                    <li class=" ">
                      
                        <a href="https://www.milehighreport.com/broncos-podcasts">
                          Broncos Podcasts
                        </a>
                      
                      
                    </li>
                    
                    <li class=" ">
                      
                        <a href="https://www.milehighreport.com/broncos-film-breakdown">
                          Broncos Film Room
                        </a>
                      
                      
                    </li>
                    
                  
                    </div>
                  
                
                  
                    <div class="c-nav-list__col">
                  
                    
                    <li class=" ">
                      
                        <a href="https://www.milehighreport.com/broncos-roster">
                          Broncos Roster
                        </a>
                      
                      
                    </li>
                    
                    <li class=" ">
                      
                        <a href="https://www.milehighreport.com/broncos-injuries">
                          Broncos Injury Updates
                        </a>
                      
                      
                    </li>
                    
                    <li class=" ">
                      
                        <a href="/archives/full">
                          Full Archive
                        </a>
                      
                      
                    </li>
                    
                  
                    </div>
                  
                
                
              </ul>
            
          
        </li>
      
        <li data-nav-item-id="broncos" data-nav-list-id="broncos">
        
          <a class="c-nav-list__label" href="http://www.sbnation.com/nfl/teams/denver-broncos">
            Broncos
            
              <span class="c-nav-list__arrow-down"><svg role="img"><use xlink:href="#icon-norgie-down"></use></svg></span>
            
          </a>
          
        

         
            
            
              <ul class="c-nav-list__sub-items">
                
                  
                    
                    <li class=" ">
                      
                        <a href="http://www.sbnation.com/nfl/teams/denver-broncos#stories">
                          Stories
                        </a>
                      
                      
                    </li>
                    
                    <li class=" ">
                      
                        <a href="http://www.sbnation.com/nfl/teams/denver-broncos#schedule">
                          Schedule
                        </a>
                      
                      
                    </li>
                    
                    <li class=" ">
                      
                        <a href="http://www.sbnation.com/nfl/teams/denver-broncos#roster">
                          Roster
                        </a>
                      
                      
                    </li>
                    
                    <li class=" ">
                      
                        <a href="http://www.sbnation.com/nfl/teams/denver-broncos#stats">
                          Stats
                        </a>
                      
                      
                    </li>
                    
                  
                
                
              </ul>
            
          
        </li>
      
        <li data-nav-item-id="shop">
        
          <a class="c-nav-list__label" href="http://www.fanatics.com/NFL_Denver_Broncos/?partnerid=14104">
            Shop
            
          </a>
          
        

         
        </li>
      
        <li data-nav-item-id="about">
        
          <a class="c-nav-list__label" href="/masthead">
            About
            
          </a>
          
        

         
        </li>
      
        <li data-nav-item-id="masthead">
        
          <a class="c-nav-list__label" href="/masthead">
            Masthead
            
          </a>
          
        

         
        </li>
      
        <li data-nav-item-id="community-guidelines">
        
          <a class="c-nav-list__label" href="/community-guidelines">
            Community Guidelines
            
          </a>
          
        

         
        </li>
      
        <li data-nav-item-id="odds">
        
          <a class="c-nav-list__label" href="https://dknation.draftkings.com/nfl-odds-lines">
            Odds
            
          </a>
          
        

         
        </li>
      
        <li data-nav-item-id="fantasy-football">
        
          <a class="c-nav-list__label" href="https://dknation.draftkings.com/daily-fantasy-football-dfs">
            Fantasy Football
            
          </a>
          
        

         
        </li>
      
      <button data-ui="close-nav" type="button" class="c-nav-list__close">✕</button>
    </ul>
  
  </div>
</section>


</div>


      <div class="c-ad-allowlist" data-ui="ad-allowlist" data-cid="site/ad_allowlist-1649516634_4955_259781" data-cdata='{"adblocker_allowlist_prompt_enabled":true,"messaging_urls":["https://cdn.concert.io/lib/adblock/sbnation.html"],"selector":".l-header"}'></div>

      
    </div>
    
    <style id="custom-entry-styles" type="text/css">
  
</style>

<main id="content" tabindex="-1" class="l-wrapper">
  <article class="l-segment l-main-content">
    <span data-content-admin-id="22779148"></span>
    <div class="l-segment">
  
  <div class="c-entry-hero c-entry-hero--default ">
  
  
<div class="c-entry-group-labels c-entry-group-labels--article">
  <p class="sr-only c-entry-box--compact__labels-title" id="heading-label--azqd7nj">Filed under:</p>
  
  
    

      <ul aria-labelledby="heading-label--azqd7nj">
        
          <li class="c-entry-group-labels__item">
            <a href="https://www.milehighreport.com/broncos-draft-class-2022">
              <span>Denver Broncos 2022 Draft</span>
            </a>
          </li>
        
      </ul>
      
    
  
  
</div>

  <div class="c-entry-hero__header-wrap">
    <h1 class="c-page-title">What do NFL Draft analysts say about the Broncos’ top 30 NFL Draft visits thus far?</h1>

    
  </div>
  <p class="c-entry-summary p-dek">We know half of the Broncos’ official 30 visits. What do they tell us about Paton’s plan for draft day?</p>

  
    <div class="c-byline">
  <span class="c-byline-wrapper">
    
      By
      <span class="c-byline__item">
        
          
          <a href="https://www.sbnation.com/users/Just_JoRo" data-analytics-link="author-name"><span class="c-byline__author-name">Just_JoRo</span></a>
        
      </span>
      
        
          <span class="c-byline__item">
            
            <time class="c-byline__item" data-ui="timestamp" datetime="2022-04-09T10:00:00">
  Apr  9, 2022,  4:00am MDT
</time>
          </span>
        
      
      
      
    
    
      <span class="c-byline__item">
        <div class="c-entry-stat--words">
  <a href="https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far#comments" data-ui="comment">
    
      <span class="coral-count" data-coral-url="https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"></span>
    
    <span class="c-entry-stat--words__unread" data-ui="unread">
      / <span class="c-entry-stat__comment-data" data-ui="unread-data"></span>
      <span class="c-entry-stat--words__word">new</span>
    </span>
  </a>
</div>

      </span>
    
  </span>
  <span class="c-byline__gear">
    <a data-entry-admin="22779148" data-cid="tools/entry_admin_button-1649516448_7722_358052" data-cdata='{"id":22779148}'></a>

  </span>
</div>


  
  <div class="c-group-disclosure-ecomm">
  <p class="c-group-discolure-ecomm__text p-dek">If you buy something from an SB Nation link, Vox Media may earn a commission. See our <a href="https://www.sbnation.com/pages/guiding-principles" target="_blank">ethics statement</a>.</p>
</div>

</div>


<div class="c-social-buttons c-social-buttons--popover main-social" data-cid="site/social_buttons_list/popover-1649516448_5370_358053" data-cdata='{"entry_id":22779148,"services":["twitter","facebook","reddit","pocket","flipboard","email"],"base_url":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"}'>
  <h2 class="sr-only" id="heading-label--dibs6x4m">Share this story</h2>
  <ul aria-labelledby="heading-label--dibs6x4m">
  
    <li>
      <a class="c-social-buttons__item c-social-buttons__facebook" href="https://www.facebook.com/sharer/sharer.php?text=What+do+NFL+Draft+analysts+say+about+the+Broncos%E2%80%99+top+30+NFL+Draft+visits+thus+far%3F&amp;u=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" data-analytics-social="facebook">
        <svg role="img" class="p-svg-icon c-social-buttons__svg"><use xlink:href="#icon-facebook"></use></svg>
        <span class="sr-only">Share this on Facebook</span>
      </a>
    </li>
  
  
    <li>
      <a class="c-social-buttons__item c-social-buttons__twitter" href="https://twitter.com/intent/tweet?counturl=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far&amp;text=What+do+NFL+Draft+analysts+say+about+the+Broncos%E2%80%99+top+30+NFL+Draft+visits+thus+far%3F&amp;url=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far&amp;via=MileHighReport" data-analytics-social="twitter">
        <svg role="img" class="p-svg-icon c-social-buttons__svg"><use xlink:href="#icon-twitter"></use></svg>
        <span class="sr-only">Share this on Twitter</span>
      </a>
    </li>
  
  
  
    <li data-ui="more">
      <a class="c-social-buttons__item c-social-buttons__more" href="#" role="button" aria-expanded="false">
        <svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 21 20" class="p-svg-icon c-social-buttons__svg">
<path d="M18.4,12.9c-0.3,0-0.6,0.3-0.6,0.6V17c0,1-0.8,1.8-1.8,1.8H3c-1,0-1.8-0.8-1.8-1.8V4C1.2,3,2,2.2,3,2.2h8.4
  c0.3,0,0.6-0.3,0.6-0.6S11.7,1,11.3,1H3C1.3,1,0,2.3,0,4V17c0,1.6,1.3,3,3,3H16c1.6,0,3-1.3,3-3v-3.5C19,13.2,18.7,12.9,18.4,12.9z"></path>
<path d="M20.9,5.3C20.9,5.3,20.9,5.3,20.9,5.3c0-0.1,0-0.1,0-0.1c0,0,0,0,0-0.1c0,0,0,0,0-0.1c0,0,0,0,0-0.1c0,0,0,0,0,0
  c0,0,0,0,0,0c0,0,0,0,0,0l-4.6-4.6c-0.2-0.2-0.6-0.2-0.8,0s-0.2,0.6,0,0.8l3.3,3.3c-2.1-0.3-5.5-0.3-8.5,1.5
  C7.6,7.5,5.9,10,5.2,13.5c-0.1,0.3,0.1,0.6,0.5,0.7c0,0,0.1,0,0.1,0c0.3,0,0.5-0.2,0.6-0.5c0.6-3.1,2.1-5.4,4.3-6.8
  c3-1.8,6.7-1.5,8.5-1.2l-3.8,3.9c-0.2,0.2-0.2,0.6,0,0.8c0.1,0.1,0.3,0.2,0.4,0.2s0.3-0.1,0.4-0.2l4.6-4.6c0,0,0,0,0,0
  c0,0,0,0,0-0.1c0,0,0,0,0,0c0,0,0,0,0-0.1c0,0,0,0,0-0.1c0,0,0,0,0,0c0,0,0,0,0,0c0,0,0,0,0-0.1C20.9,5.4,20.9,5.4,20.9,5.3
  C20.9,5.4,20.9,5.4,20.9,5.3z"></path>
</svg>
        <span class="c-social-buttons--label" aria-hidden="true">Share</span>
        <span class="sr-only">All sharing options</span>
      </a>
    </li>
  
    
  </ul>
  
    <div class="c-social-buttons__popover" data-ui="popover">
      <div class="c-social-buttons__popover-header">
        <h3 tabindex="-1">
          <strong aria-hidden="true">Share</strong>
          <span class="sr-only">All sharing options for:</span>
          <span>What do NFL Draft analysts say about the Broncos’ top 30 NFL Draft visits thus far?</span>
        </h3>
      </div>
      <div class="c-social-buttons__popover-body">
        <ul>
          
            
              <li>
                <a class="c-social-buttons__item c-social-buttons__reddit" href="https://reddit.com/submit?title=What+do+NFL+Draft+analysts+say+about+the+Broncos%E2%80%99+top+30+NFL+Draft+visits+thus+far%3F&amp;url=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" data-analytics-social="reddit">
                  <svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 17 17" class="p-svg-icon c-social-buttons__svg">
<path d="M8.5,0C3.8,0,0,3.8,0,8.5S3.8,17,8.5,17S17,13.2,17,8.5S13.2,0,8.5,0z M14,10.2c0,0.1,0,0.3,0,0.4c0,2.2-2.5,3.9-5.6,3.9
  s-5.6-1.8-5.6-3.9c0-0.2,0-0.3,0-0.5C2.5,9.9,2.2,9.4,2.2,8.9c0-0.8,0.6-1.5,1.4-1.5c0.4,0,0.7,0.2,0.9,0.4C5.2,7.3,6,6.9,7,6.8
  c0.3-0.1,0.3-0.1,0.7-0.1l0.7-3.1C8.6,2.9,8.8,2.9,9.3,3C11.1,3.5,12,3.7,12,3.7c0.2-0.3,0.5-0.3,0.8-0.3c0.6,0,1.1,0.5,1.1,1.2
  s-0.5,1.2-1.1,1.2c-0.5,0-1-0.5-1.1-1c0,0-0.7-0.2-2.2-0.6C9.1,5.9,8.9,6.7,8.9,6.7c1.3,0.1,2.6,0.5,3.5,1.1c0.3-0.3,0.6-0.4,1-0.4
  c0.8,0,1.4,0.7,1.4,1.5C14.8,9.4,14.5,9.9,14,10.2z"></path>
<path d="M10.2,12.2c-0.3,0.4-0.9,0.5-1.7,0.5l0,0l0,0c-0.8,0-1.4-0.2-1.7-0.5c-0.1-0.1-0.2-0.1-0.3,0c-0.1,0.1-0.1,0.2,0,0.3
  c0.4,0.4,1.1,0.7,2,0.7l0,0l0,0c0.9,0,1.6-0.2,2-0.7c0.1-0.1,0.1-0.2,0-0.3C10.4,12.1,10.3,12.1,10.2,12.2z"></path>
<ellipse cx="6.6" cy="9.9" rx="0.8" ry="0.9"></ellipse>
<ellipse cx="10.4" cy="9.9" rx="0.8" ry="0.9"></ellipse>
</svg>
                  <span class="c-social-buttons__text">Reddit</span>
                </a>
              </li>
            
          
            
              <li>
                <a class="c-social-buttons__item c-social-buttons__pocket" href="https://getpocket.com/save?url=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" data-analytics-social="pocket">
                  <svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 16 14" class="p-svg-icon c-social-buttons__svg">
<path d="M14.4,0.1H2c-0.6,0-1.1,0.5-1.1,1.1v4.6c0,4,3.3,7.3,7.3,7.3c4,0,7.3-3.3,7.3-7.3V1.2C15.5,0.6,15,0.1,14.4,0.1
  z M12.5,5.4L8.9,9C8.7,9.2,8.4,9.3,8.2,9.3C8,9.3,7.7,9.2,7.5,9L3.9,5.4C3.5,5,3.5,4.4,3.9,4c0.4-0.4,1-0.4,1.3,0l3,3l3-3
  c0.4-0.4,1-0.4,1.3,0C12.9,4.4,12.9,5,12.5,5.4z"></path>
</svg>
                  <span class="c-social-buttons__text">Pocket</span>
                </a>
              </li>
            
          
            
              <li>
                <a class="c-social-buttons__item c-social-buttons__flipboard" href="https://share.flipboard.com/bookmarklet/popout?title=What+do+NFL+Draft+analysts+say+about+the+Broncos%E2%80%99+top+30+NFL+Draft+visits+thus+far%3F&amp;url=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far&amp;v=2" data-analytics-social="flipboard">
                  <svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 16 16" class="p-svg-icon c-social-buttons__svg">
  <path d="M0,0v16h16V0H0z M12.9,6.4H9.6v3.2H6.5v3.2H3.2V3.2h9.7V6.4z"></path>
  <polygon opacity="0.13" points="6.5,3.2 6.5,6.4 9.8,6.4 12.9,6.4 12.9,3.2 "></polygon>
  <polygon opacity="0.23" points="6.5,9.7 9.7,9.7 9.7,6.4 6.5,6.4 "></polygon>
</svg>
                  <span class="c-social-buttons__text">Flipboard</span>
                </a>
              </li>
            
          
            
              <li>
                <a class="c-social-buttons__item c-social-buttons__email" href="mailto:?subject=What%20do%20NFL%20Draft%20analysts%20say%20about%20the%20Broncos%E2%80%99%20top%2030%20NFL%20Draft%20visits%20thus%20far%3F&amp;body=We%20know%20half%20of%20the%20Broncos%E2%80%99%20official%2030%20visits.%20What%20do%20they%20tell%20us%20about%20Paton%E2%80%99s%20plan%20for%20draft%20day%3F%0A%0Ahttps%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" data-analytics-social="email">
                  <svg role="img" class="p-svg-icon c-social-buttons__svg"><use xlink:href="#icon-email"></use></svg>
                  <span class="c-social-buttons__text">Email</span>
                </a>
              </li>
            
          
        </ul>
      </div>
      <span class="c-social-buttons__popover-caret" data-ui="caret"></span>
    </div>
  
</div>


  
  
  
</div>
<div class="l-sidebar-fixed l-segment l-article-body-segment">
  <div class="l-col__main">
    
    







<div class="c-entry-content ">
  <div id="tUdiYL"><iframe frameborder="0" height="200" scrolling="no" src="https://playlist.megaphone.fm?e=VMP4510407945&amp;light=true" width="100%"></iframe></div>
<p id="qS4OlS">There’s less than three weeks before the <a href="https://www.milehighreport.com">Denver Broncos</a> will make their first selection in the <a href="https://www.sbnation.com/nfl-draft">2022 NFL Draft</a>. The Russell Wilson trade means franchise quarterback is presumably solved, but now George Paton has limited draft capital to address the rest of his team’s needs. </p>
<p id="d2NPRW">This week AJ Schulte and I discussed what that really means for the upcoming rookie class on Cover 2 Broncos, but one thing I wanted to spend more time chewing on is the kind of prospects Denver’s showing interest in. Every team is provided 30 “official” visits to speak with and vet draft prospects, and Mile High Report’s already aware of half of Paton’s. What do national draft analysts have to say about the prospective Broncos? To get a better idea, I started sleuthing. </p>
<p id="ZlSd4G">What follows is a running list of the visits we know the Broncos will have before the draft at the end of the month, along summaries from Dane Brugler of the Athletic, Brandon Thorn, Cory Giddings, Nate Tice, and Derrik Klassen of Bleacher Report, Nathan Cooper, Terrance Stokes, II, Ben Hrkach, Jacob Halleen, Jonathan Drillings,<strong> </strong>Alec Mallon, Joe McDonald, Max Nuscher, John Todd, Kendall Mirsky, Lucas Reimink, and Jordan Edwards<strong> </strong>of Sports Info Solutions. Each summary has a link to the author’s full report. I recommend you check them out to learn more.</p>
<h2 id="dgTzuw"><strong>OT Tyler Smith - Tulsa</strong></h2>
<blockquote><p id="VQ4VkK">Smith is incredibly raw, but he has the play strength and physical traits to get significantly better with technical and mental development. There is a sizable gap between where he is now and his ceiling as a potential NFL starter and will require a patient coaching staff ready for a project.</p></blockquote>
<p id="SWCyof"><a href="https://go.redirectingat.com?id=66960X1641777&amp;xs=1&amp;url=https%3A%2F%2Ftheathletic.com%2F3233612%2F2022%2F04%2F07%2F2022-nfl-draft-guide-the-beast-dane-brugler%2F%3Fsource%3Ddailyemail%26campaign%3D601983&amp;referrer=sbnation.com&amp;sref=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" rel="sponsored nofollow noopener" target="_blank" has-subtag="true" data-cdata='{"rewritten_url":"https://go.redirectingat.com?xcust=___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder\u0026id=66960X1641777\u0026xs=1\u0026url=https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983\u0026referrer=sbnation.com\u0026sref=https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","subtag_max_length":50,"subtag_delim_length":3,"subtag_key":"xcust","subtag_data":{"xcust":"___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder","id":"66960X1641777","xs":"1","url":"https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983","referrer":"sbnation.com","sref":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"},"encode_subtag":false}'>- Dane Brugler</a></p>
<blockquote><p id="CM34xJ">Smith has the physical traits and aggressive nature to become an eventual NFL starter. However, he is as raw as sushi and a penalty machine who needs to reconfigure his technique from the ground up before he can see an NFL field.</p></blockquote>
<p id="GGgANA"><a href="https://bleacherreport.com/articles/10026447-tyler-smith-nfl-draft-2022-scouting-report-for-tulsa-ot">- Brandon Thorn</a></p>
<blockquote><p id="1Qy2s3">Due to his skill set Smith projects best as a starting right tackle in a zone scheme or a gap scheme that doesn’t ask its tackles to pull often. He can eventually play left tackle, but he needs to become more refined and continue developing in pass pro. He’s a strong blocker in the run game and holds a good anchor, but he can get very grabby and lose control of his fundamentals at times.</p></blockquote>
<p id="Y37ZnN"><a href="https://nfldraft.sportsinfosolutions.com/prospect/tyler-smith">- Nathan Cooper</a></p>
<aside id="0wdYrc"><div class="c-read-more">
  <p class="c-read-more__intro">
    Related
  </p>

  
    <h4><a data-analytics-link="readmore" href="https://www.milehighreport.com/2022/4/7/23012482/2022-nfl-draft-profile-tyler-smith">2022 NFL Draft Profile: Tulsa OT Tyler Smith </a></h4>
  
</div>
</aside><h2 id="9Rkv2a">
<strong>OT Abraham Lucas - </strong><a href="https://www.cougcenter.com"><strong>Washington State</strong></a>
</h2>
<blockquote><p id="sNOsVA">Lucas is not an explosive mover and his hand exchange must improve versus NFL-level competition, but he has a massive frame and the balanced athleticism to keep his man blocked. He projects as a low-ceiling starting right tackle in the NFL.</p></blockquote>
<p id="sM0k46"><a href="https://go.redirectingat.com?id=66960X1641777&amp;xs=1&amp;url=https%3A%2F%2Ftheathletic.com%2F3233612%2F2022%2F04%2F07%2F2022-nfl-draft-guide-the-beast-dane-brugler%2F%3Fsource%3Ddailyemail%26campaign%3D601983&amp;referrer=sbnation.com&amp;sref=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" rel="sponsored nofollow noopener" target="_blank" has-subtag="true" data-cdata='{"rewritten_url":"https://go.redirectingat.com?xcust=___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder\u0026id=66960X1641777\u0026xs=1\u0026url=https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983\u0026referrer=sbnation.com\u0026sref=https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","subtag_max_length":50,"subtag_delim_length":3,"subtag_key":"xcust","subtag_data":{"xcust":"___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder","id":"66960X1641777","xs":"1","url":"https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983","referrer":"sbnation.com","sref":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"},"encode_subtag":false}'>- Dane Brugler </a></p>
<blockquote><p id="M1WsFC">Lucas’ size, length and raw athletic ability offer some upside as a developmental tackle, but he will have a steep learning curve in the NFL, with his technique from the ground up needing to be retooled.</p></blockquote>
<p id="jO474C"><a href="https://bleacherreport.com/articles/10021412-abraham-lucas-nfl-draft-2022-scouting-report-for-washington-state-ot">- Brandon Thorn</a></p>
<blockquote><p id="2MaUMY">Lucas projects as a backup swing tackle at the next level. Though he played exclusively on the right side in college, his feet, steady play, and crafty pass pro skills should afford him the ability to play on the left in a pinch. Due to his lack of power, he projects best in a zone-run scheme on a pass-happy offense, though he needs to improve his first step to become a consistent player in the run game. He is a high IQ player that should take well to coaching at the next level. He was clearly more comfortable in the Air Raid system he was recruited into and is still improving as a run blocker.</p></blockquote>
<p id="6JcRDf"><a href="https://nfldraft.sportsinfosolutions.com/prospect/abraham-lucas">Terrance Stokes, II &amp; Ben Hrkach</a></p>
<div id="X5TiCU">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr">Washington State OT Abraham Lucas is one of my favorite tackles in the 2021 class.<br><br>Great athlete, very long at 6’7, and arguably the most smooth pass protector in the class.<br><br>Lucas(75) against Kayvon Thibodeaux(5). Lucas is patient, his hands eliminate any pass rush move. <a href="https://t.co/q98aiJMUcO">pic.twitter.com/q98aiJMUcO</a></p>— Commander Matt Valdovinos (@MVScouting) <a href="https://twitter.com/MVScouting/status/1264330831625179136?ref_src=twsrc%5Etfw">May 23, 2020</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="Hy7z57"><strong>OT Matt Waletzko - North Dakota</strong></h2>
<blockquote><p id="lfJ1Ox">Waletzko has length that cannot be coached along with functional foot/body quickness, but he must continue developing his strength and stature before he is ready for live NFL reps. He has legitimate NFL upside but will require patience. </p></blockquote>
<p id="jqYE0H"><a href="https://go.redirectingat.com?id=66960X1641777&amp;xs=1&amp;url=https%3A%2F%2Ftheathletic.com%2F3233612%2F2022%2F04%2F07%2F2022-nfl-draft-guide-the-beast-dane-brugler%2F%3Fsource%3Ddailyemail%26campaign%3D601983&amp;referrer=sbnation.com&amp;sref=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" rel="sponsored nofollow noopener" target="_blank" has-subtag="true" data-cdata='{"rewritten_url":"https://go.redirectingat.com?xcust=___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder\u0026id=66960X1641777\u0026xs=1\u0026url=https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983\u0026referrer=sbnation.com\u0026sref=https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","subtag_max_length":50,"subtag_delim_length":3,"subtag_key":"xcust","subtag_data":{"xcust":"___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder","id":"66960X1641777","xs":"1","url":"https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983","referrer":"sbnation.com","sref":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"},"encode_subtag":false}'>- Dane Brugler </a></p>
<blockquote><p id="iW4ypy">Waletzko has the length and athletic ability to offer some developmental upside as a practice squad player, but his minimal contact balance, play strength and technical concerns make him a liability on an NFL field for the foreseeable future.</p></blockquote>
<p id="ubKHLj"><a href="https://bleacherreport.com/articles/10021409-matt-waletzko-nfl-draft-2022-scouting-report-for-north-dakota-ot">- Brandon Thorn</a></p>
<blockquote><p id="LMRh5I">Waletzko projects as a backup left tackle at the next level. He is best suited in a zone-heavy run scheme so he can use his movement skills and finishing abilities. Because he is more of a finesse player, his lack of power will keep him on the left side of the line. Waletzko has the raw physical tools and is a high-upside player, but will need to add strength and refine his technique.</p></blockquote>
<p id="kPU9XH"><a href="https://nfldraft.sportsinfosolutions.com/prospect/matt-waletzko">- Jacob Halleen</a></p>
<div id="o9lABn">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr">North Dakota’s Matt Waletzko is prime example of why most NFL grading scales reflect a 3-year window. <a href="https://twitter.com/matt_waletzko?ref_src=twsrc%5Etfw">@matt_waletzko</a> needs time in weight room but many teams have developmental starter grades on him because of upside in pass pro. Could be Day 3 steal.<a href="https://twitter.com/hashtag/TheDraftStartsInMOBILE?src=hash&amp;ref_src=twsrc%5Etfw">#TheDraftStartsInMOBILE</a>™️ <a href="https://t.co/OsIYUUoBmB">pic.twitter.com/OsIYUUoBmB</a></p>— Jim Nagy (@JimNagy_SB) <a href="https://twitter.com/JimNagy_SB/status/1504571342418554887?ref_src=twsrc%5Etfw">March 17, 2022</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="gzxtW2"><strong>OT Braxton Jones - Southern Utah</strong></h2>
<blockquote><p id="sC2FVW">Jones needs improved timing, technique and anchor before he is ready for NFL reps, but his movement skills and length are outstanding foundational traits. Although he’ll require an adjustment period, he has the tools to be a starter down the road.</p></blockquote>
<p id="gtuR6x"><a href="https://go.redirectingat.com?id=66960X1641777&amp;xs=1&amp;url=https%3A%2F%2Ftheathletic.com%2F3233612%2F2022%2F04%2F07%2F2022-nfl-draft-guide-the-beast-dane-brugler%2F%3Fsource%3Ddailyemail%26campaign%3D601983&amp;referrer=sbnation.com&amp;sref=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" rel="sponsored nofollow noopener" target="_blank" has-subtag="true" data-cdata='{"rewritten_url":"https://go.redirectingat.com?xcust=___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder\u0026id=66960X1641777\u0026xs=1\u0026url=https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983\u0026referrer=sbnation.com\u0026sref=https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","subtag_max_length":50,"subtag_delim_length":3,"subtag_key":"xcust","subtag_data":{"xcust":"___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder","id":"66960X1641777","xs":"1","url":"https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983","referrer":"sbnation.com","sref":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"},"encode_subtag":false}'>- Dane Brugler </a></p>
<blockquote><p id="7Er1t3">Jones has the length, grip strength and competitive toughness to warrant a look as a draftable backup quality prospect. His technique from the ground up needs to be revamped in pass protection for him to have a chance to stick long-term.</p></blockquote>
<p id="WEewU4"><a href="https://bleacherreport.com/articles/10021416-braxton-jones-nfl-draft-2022-scouting-report-for-southern-utah-ot">- Brandon Thorn</a></p>
<blockquote><p id="VPLXiY">Jones projects as a backup left tackle only player at the next level, fitting in either a zone or gap-based scheme. He needs to get much stronger in his lower half and put on more bulk, but he plays fundamentally sound football. A lot of his struggles come from a lack of strength and anchor ability, so if he improves that aspect, there’s a good chance he can find a way to stick with his other traits.</p></blockquote>
<p id="6DyH64"><a href="https://nfldraft.sportsinfosolutions.com/prospect/braxton-jones">- Nathan Cooper</a></p>
<div id="TIC92E">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr">Braxton Jones is a OT prospect in the 2022 draft class. He scored an unofficial 7.64 RAS at the Combine out of a possible 10.00. This ranked 271 out of 1146 OT from 1987 to 2022. <a href="https://t.co/BkCAxM0RrC">https://t.co/BkCAxM0RrC</a> <a href="https://twitter.com/hashtag/RAS?src=hash&amp;ref_src=twsrc%5Etfw">#RAS</a> via <a href="https://twitter.com/MathBomb?ref_src=twsrc%5Etfw">@Mathbomb</a> <a href="https://t.co/iiM0Ycq3T9">pic.twitter.com/iiM0Ycq3T9</a></p>— Kent Lee Platte (@MathBomb) <a href="https://twitter.com/MathBomb/status/1499948912454643717?ref_src=twsrc%5Etfw">March 5, 2022</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="4ECAXg"><strong>iOL Dylan Parham - Memphis</strong></h2>
<blockquote><p id="wfJXqx">Parham can play too fast at times and loses his bearings, but he has excellent movement skills and understands how to outleverage defenders and sustain the point of attack. He has the talent level to provide immediate interior depth for an NFL team and compete for a starting job, projecting best at center</p></blockquote>
<p id="4HUi3o"><a href="https://go.redirectingat.com?id=66960X1641777&amp;xs=1&amp;url=https%3A%2F%2Ftheathletic.com%2F3233612%2F2022%2F04%2F07%2F2022-nfl-draft-guide-the-beast-dane-brugler%2F%3Fsource%3Ddailyemail%26campaign%3D601983&amp;referrer=sbnation.com&amp;sref=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" rel="sponsored nofollow noopener" target="_blank" has-subtag="true" data-cdata='{"rewritten_url":"https://go.redirectingat.com?xcust=___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder\u0026id=66960X1641777\u0026xs=1\u0026url=https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983\u0026referrer=sbnation.com\u0026sref=https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","subtag_max_length":50,"subtag_delim_length":3,"subtag_key":"xcust","subtag_data":{"xcust":"___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder","id":"66960X1641777","xs":"1","url":"https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983","referrer":"sbnation.com","sref":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"},"encode_subtag":false}'>- Dane Brugler </a></p>
<blockquote><p id="WrlWWO">Parham’s mobility, core strength and ability to sustain and control defenders once latched provide a strong foundation as a run-blocker. He also has the competitive toughness to finish blocks consistently. Parham’s athletic ability will allow him to pull and work in space effectively while his processing skills lend themselves to a possible move inside at center, where his sawed-off frame may be best utilized long-term.</p></blockquote>
<p id="O2XbuB"><a href="https://bleacherreport.com/articles/10021372-dylan-parham-nfl-draft-2022-scouting-report-for-memphis-iol">- Brandon Thorn</a></p>
<blockquote><p id="sfzpBL">Parham projects as a starting-caliber guard. He is best suited as a guard, but has the communication skills and awareness to play center. He also has the versatility to be successful both in a zone or gap running scheme. It’s clear his transition from edge to tight end to offensive line is going well, but he just needs to continue filling out his frame, getting stronger, and refining his technique to be effective at the next level, because he has the skill set to do so.</p></blockquote>
<p id="0Yozyp"><a href="https://nfldraft.sportsinfosolutions.com/prospect/dylan-parham">- Jonathan Drillings</a></p>
<div id="cNOVFn">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr"><a href="https://twitter.com/hashtag/Memphis?src=hash&amp;ref_src=twsrc%5Etfw">#Memphis</a> iOL Dylan Parham doesn’t get enough pub. <br><br>Love his knee bend, core strength, and balance in pass protection on tape. Showing the same thing during SB practice. <a href="https://t.co/qDWIEIMzdw">pic.twitter.com/qDWIEIMzdw</a></p>— Dane Brugler (@dpbrugler) <a href="https://twitter.com/dpbrugler/status/1488718865416822785?ref_src=twsrc%5Etfw">February 2, 2022</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="ENQC9p"><strong>iOL Cole Strange - Chattanooga</strong></h2>
<blockquote><p id="FCPnex">Strange struggles to recover once defenders gain the upper hand, but he works hard to stay balanced with his quick feet, strong hands and competitive toughness. He will be ready to compete for an NFL starting job (guard or center) in year one.</p></blockquote>
<p id="Sqmbwg"><a href="https://go.redirectingat.com?id=66960X1641777&amp;xs=1&amp;url=https%3A%2F%2Ftheathletic.com%2F3233612%2F2022%2F04%2F07%2F2022-nfl-draft-guide-the-beast-dane-brugler%2F%3Fsource%3Ddailyemail%26campaign%3D601983&amp;referrer=sbnation.com&amp;sref=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" rel="sponsored nofollow noopener" target="_blank" has-subtag="true" data-cdata='{"rewritten_url":"https://go.redirectingat.com?xcust=___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder\u0026id=66960X1641777\u0026xs=1\u0026url=https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983\u0026referrer=sbnation.com\u0026sref=https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","subtag_max_length":50,"subtag_delim_length":3,"subtag_key":"xcust","subtag_data":{"xcust":"___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder","id":"66960X1641777","xs":"1","url":"https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983","referrer":"sbnation.com","sref":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"},"encode_subtag":false}'>- Dane Brugler </a></p>
<blockquote><p id="oc7aJ5">Strange has the frame, athletic ability, play strength and competitive toughness to be considered a high-level backup at multiple positions across the line, with starter potential over his first few seasons at guard. He will need refinement to handle himself in isolated situations as a pass protector in the NFL and to learn how to more efficiently win back leverage as a run-blocker, but he has shown that he can dominate FCS competition, and his power and tenacity translated against a major bump up in competition against Kentucky as well as at the <a href="http://www.sbnation.com/senior-bowl">Senior Bowl</a>.</p></blockquote>
<p id="lmgzb7"><a href="https://bleacherreport.com/articles/10021427-cole-strange-nfl-draft-2022-scouting-report-for-chattanooga-iol">- Brandon Thorn</a></p>
<blockquote><p id="FbCYy1">Strange projects best as a scheme-versatile left guard, fits all three interior line positions. His nastiness, strength, and movement skills allow him to be a solid guard at the next level work in zone or as a puller in a gap scheme. He also has the short-set anchor ability and hand quickness to hold up in pass pro along the interior, though he does need to fill out his frame a bit more.</p></blockquote>
<p id="hESbgi"><a href="https://nfldraft.sportsinfosolutions.com/prospect/cole-strange">- Nathan Cooper</a></p>
<div id="ojd4Se">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr">The <a href="https://twitter.com/hashtag/Bears?src=hash&amp;ref_src=twsrc%5Etfw">#Bears</a> want speed and nastiness along their OL. I think Chattanooga LG/C Cole Strange is a perfect fit for this team.<br><br>He’s a nasty SOB along the interior who buries defenders, and he has a 9.95 <a href="https://twitter.com/hashtag/RAS?src=hash&amp;ref_src=twsrc%5Etfw">#RAS</a>. Shades of Quinn Meinerz from last year. <a href="https://t.co/3S14N6g3c9">pic.twitter.com/3S14N6g3c9</a></p>— Jacob Infante (@jacobinfante24) <a href="https://twitter.com/jacobinfante24/status/1507812890035859459?ref_src=twsrc%5Etfw">March 26, 2022</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="r6WDLW"><strong>iOL Cam Jurgens - Nebraska</strong></h2>
<blockquote><p id="KcZ6xx">Jurgens lacks the brute power to easily control defenders, but he is a twitched-up athlete with play quickness and competitive toughness that will translate to the NFL. He is the round two version of Iowa’s Tyler Linderbaum and will grow into a starter for a zone-based offense</p></blockquote>
<p id="4SIDiC"><a href="https://go.redirectingat.com?id=66960X1641777&amp;xs=1&amp;url=https%3A%2F%2Ftheathletic.com%2F3233612%2F2022%2F04%2F07%2F2022-nfl-draft-guide-the-beast-dane-brugler%2F%3Fsource%3Ddailyemail%26campaign%3D601983&amp;referrer=sbnation.com&amp;sref=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" rel="sponsored nofollow noopener" target="_blank" has-subtag="true" data-cdata='{"rewritten_url":"https://go.redirectingat.com?xcust=___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder\u0026id=66960X1641777\u0026xs=1\u0026url=https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983\u0026referrer=sbnation.com\u0026sref=https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","subtag_max_length":50,"subtag_delim_length":3,"subtag_key":"xcust","subtag_data":{"xcust":"___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder","id":"66960X1641777","xs":"1","url":"https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983","referrer":"sbnation.com","sref":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"},"encode_subtag":false}'>- Dane Brugler </a></p>
<blockquote><p id="C8kuIO">Jurgens needs to prove he can add and maintain more weight on his frame, and he will likely require guard help built into whatever scheme he lands in to help him in pass protection. But he is still relatively new to the offensive line, with excellent athletic ability, explosiveness and competitive toughness to offer as a high-end developmental center with starter potential.</p></blockquote>
<p id="4yCR18"><a href="https://bleacherreport.com/articles/10026432-cam-jurgens-nfl-draft-2022-scouting-report-for-nebraska-iol">- Brandon Thorn</a></p>
<blockquote><p id="0zZiga">Jurgens is a suitable starting center who will thrive in a zone scheme. He lacks the bulk and strength to play as a guard consistently. He has ideal movement skills and the demeanor offensive line coaches desire. He needs to improve on the finer points of pass pro and can be too aggressive at times, but these deficiencies are coachable and his innate athleticism is hard to find.</p></blockquote>
<p id="lUuyKk"><a href="https://nfldraft.sportsinfosolutions.com/prospect/cam-jurgens">- Ben Hrkach</a></p>
<div id="vwynrb">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr">After watching Nebraska center Cam Jurgens this morning, he’s towards the top of my list for Miami at pick 101. <br><br>Needs development, but he’s a scheme fit with a ton of athletic upside. <a href="https://t.co/dWwqrtH5as">pic.twitter.com/dWwqrtH5as</a></p>— Dante Collinelli (@DanteCollinelli) <a href="https://twitter.com/DanteCollinelli/status/1507355598198878209?ref_src=twsrc%5Etfw">March 25, 2022</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="H47uWP">
<strong>CB Cordale Flott - </strong><a href="https://www.andthevalleyshook.com"><strong>LSU</strong></a>
</h2>
<blockquote><p id="NkFF22">Flott has slick hips to turn and run on command with inside-outside versatility, but he trusts his athleticism more than his technique with below average size and questionable playmaking instincts</p></blockquote>
<p id="MkSQPr"><a href="https://go.redirectingat.com?id=66960X1641777&amp;xs=1&amp;url=https%3A%2F%2Ftheathletic.com%2F3233612%2F2022%2F04%2F07%2F2022-nfl-draft-guide-the-beast-dane-brugler%2F%3Fsource%3Ddailyemail%26campaign%3D601983&amp;referrer=sbnation.com&amp;sref=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" rel="sponsored nofollow noopener" target="_blank" has-subtag="true" data-cdata='{"rewritten_url":"https://go.redirectingat.com?xcust=___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder\u0026id=66960X1641777\u0026xs=1\u0026url=https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983\u0026referrer=sbnation.com\u0026sref=https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","subtag_max_length":50,"subtag_delim_length":3,"subtag_key":"xcust","subtag_data":{"xcust":"___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder","id":"66960X1641777","xs":"1","url":"https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983","referrer":"sbnation.com","sref":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"},"encode_subtag":false}'>- Dane Brugler </a></p>
<blockquote><p id="pm7b2L">Cordale Flott is a versatile athlete with the ability to play as a nickel defender or as an outside cornerback. He has excellent height and length that serves well in both positions...He will need to continue to work on adding weight to his frame, as well as increasing his strength for the next level. His skills and versatility may intrigue NFL executives, but ultimately, he will be a high-level developmental prospect who may pay dividends a couple years into his career.</p></blockquote>
<p id="eLnY1a"><a href="https://bleacherreport.com/articles/10026407-cordale-flott-nfl-draft-2022-scouting-report-for-lsu-cb">- Cory Giddings</a></p>
<blockquote><p id="EBppUC">Flott best projects as a solid nickel cornerback at the next level with good position flexibility. Flott has more experience and a suitable skill set inside, but his best role may be on the perimeter. He is scheme versatile, with plenty of traits for a press man corner because of his athleticism and physical play style, but also solid zone range and ball skills. His feisty aggression makes his recognized play strength greater than his true physical strength and size, which will need to be further developed moving forward with added bulk to fill out his frame. Flott projects as a strong special teamer and could see time on both kickoff and punt units due to his ability to get down the field quickly and throw his body around.</p></blockquote>
<p id="KRGdbt">-<a href="https://nfldraft.sportsinfosolutions.com/prospect/cordale-flott"> Alec Mallon &amp; Joe McDonald</a></p>
<div id="w0ZhDy">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr">Impressive interception from LSU CB Cordale Flott. Likely an early day three pick. Excellent awareness of the receiver sneaking behind him. Maintains enough depth, reads the QBs and makes an acrobatic catch. <a href="https://t.co/ASBmvZw0CP">pic.twitter.com/ASBmvZw0CP</a></p>— Evan Lazar (@ezlazar) <a href="https://twitter.com/ezlazar/status/1512148863196581897?ref_src=twsrc%5Etfw">April 7, 2022</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="XHNEdz"><strong>WR Tyquan Thornton - Baylor</strong></h2>
<blockquote><p id="arazw9">Thornton will have a tougher time masking his lack of build or play strength vs. NFL competition, but his speed plays at any level, and his midair adjustment skills could be what keep him on an NFL roster.</p></blockquote>
<p id="mAK5zL"><a href="https://go.redirectingat.com?id=66960X1641777&amp;xs=1&amp;url=https%3A%2F%2Ftheathletic.com%2F3233612%2F2022%2F04%2F07%2F2022-nfl-draft-guide-the-beast-dane-brugler%2F%3Fsource%3Ddailyemail%26campaign%3D601983&amp;referrer=sbnation.com&amp;sref=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" rel="sponsored nofollow noopener" target="_blank" has-subtag="true" data-cdata='{"rewritten_url":"https://go.redirectingat.com?xcust=___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder\u0026id=66960X1641777\u0026xs=1\u0026url=https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983\u0026referrer=sbnation.com\u0026sref=https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","subtag_max_length":50,"subtag_delim_length":3,"subtag_key":"xcust","subtag_data":{"xcust":"___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder","id":"66960X1641777","xs":"1","url":"https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983","referrer":"sbnation.com","sref":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"},"encode_subtag":false}'>- Dane Brugler</a></p>
<blockquote><p id="MTEUcq">Thornton will be able to contribute early in his career as a deep threat who can take the top off defenses with his legit track speed. He is an adequate route-runner but will need more polish to be more useful on a down-to-down basis. Thornton is also a willing blocker for teammates and does not shy away from being physical despite his skinny frame, which might indicate some special teams potential as a gunner. His lack of consistent hands through contact will make or break his upside for a more prominent role. But teams will find immediate use for his ability in the red zone and of course his speed to open things up underneath for other options, with traits for outside starter potential down the road with continued development.</p></blockquote>
<p id="SApxIH"><a href="https://bleacherreport.com/articles/10026557-tyquan-thornton-nfl-draft-2022-scouting-report-for-baylor-wr">- Nate Tice</a></p>
<blockquote><p id="cog6AN">Thornton projects as a No. 4 receiver at the next level. He projects best as an outside receiver, because of his long frame and good speed. On 3rd downs and obvious passing situations, he will line up outside and use his speed and deep playmaking ability to take the top off the defense. He can also use his skills off the line in the red zone. He will need to improve his route running if he wants to see the field more. He doesn’t have much special teams experience in college, outside of being a kick returner, but has the speed and enough toughness to be a contributor in some areas.</p></blockquote>
<p id="ka4TTX"><a href="https://nfldraft.sportsinfosolutions.com/prospect/tyquan-thornton">- Max Nuscher</a></p>
<div id="SvC80h">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr">Baylor's Tyquan Thornton is a solid day 3 WR for the <a href="https://twitter.com/hashtag/Giants?src=hash&amp;ref_src=twsrc%5Etfw">#Giants</a> to consider<br><br>☑️ Fastest 40 at the Combine checks out with his play speed<br><br>☑️ Easy separator, smooth athlete<br><br>☑️  Good COD/SAQ for taller WR<br><br>☑️ Large 33+ inch arms<br><br>Speed is key in the NFL. TT offers that at a value <a href="https://t.co/BONTqej0UJ">pic.twitter.com/BONTqej0UJ</a></p>— Nick Falato (@nickfalato) <a href="https://twitter.com/nickfalato/status/1512068175042473984?ref_src=twsrc%5Etfw">April 7, 2022</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="3OW624"><strong>ED Isaiah Thomas - Oklahoma</strong></h2>
<blockquote><p id="Zs6n4i">Thomas has subpar get-off quickness and finishing skills, but he has NFL-level size, length and strength to be a rotational defensive end in a 4-3 base defense, kicking inside in sub packages.</p></blockquote>
<p id="z55shp"><a href="https://go.redirectingat.com?id=66960X1641777&amp;xs=1&amp;url=https%3A%2F%2Ftheathletic.com%2F3233612%2F2022%2F04%2F07%2F2022-nfl-draft-guide-the-beast-dane-brugler%2F%3Fsource%3Ddailyemail%26campaign%3D601983&amp;referrer=sbnation.com&amp;sref=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" rel="sponsored nofollow noopener" target="_blank" has-subtag="true" data-cdata='{"rewritten_url":"https://go.redirectingat.com?xcust=___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder\u0026id=66960X1641777\u0026xs=1\u0026url=https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983\u0026referrer=sbnation.com\u0026sref=https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","subtag_max_length":50,"subtag_delim_length":3,"subtag_key":"xcust","subtag_data":{"xcust":"___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder","id":"66960X1641777","xs":"1","url":"https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983","referrer":"sbnation.com","sref":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"},"encode_subtag":false}'>- Dane Brugler </a></p>
<blockquote><p id="fsshI1">Thomas needs a lot of work to become a starter. His lack of bend may always make him a limited player, so he must develop as a run defender and expand his pass-rushing arsenal. With that said, his explosive traits are worth a Day 3 draft pick. Thomas is likely best as a stash-and-develop type rather than someone who should vie for snaps right away.</p></blockquote>
<p id="WdWYNC"><a href="https://bleacherreport.com/articles/10026502-isaiah-thomas-nfl-draft-2022-scouting-report-for-oklahoma-edge">- Derrik Klassen</a></p>
<blockquote><p id="T20cfI">Thomas projects to be a versatile backup along the defensive line at the next level. Ideally he is a defensive end for a 4-man front defense where he can set the edge or even a 5-tech as a run defender rather than along the interior on early downs. On 3rd down, Thomas can rush the passer from a variety of alignments, but will be most productive rushing off the edge. Thomas’ length and quickness could serve a role on a punt block team, but it’s hard to envision him as a core special teamer at the next level.</p></blockquote>
<p id="5qDmRE"><a href="https://nfldraft.sportsinfosolutions.com/prospect/isaiah-thomas">- Jordan Edwards</a></p>
<div id="7PEkDt">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr">If you look at +265lb DEs that run 4.7 or less - there’s an EXCITING list of NFL talent <br><br>Only 2 from the Combine this year… We’ve talked about Travon Walker (who is a freakshow) but don’t forget Isaiah Thomas (6’5 266 4.70)<br><br>I thought Thomas was quietly damn good in Mobile! <a href="https://t.co/5Q46ZYHFrP">pic.twitter.com/5Q46ZYHFrP</a></p>— Ben Fennell (@BenFennell_NFL) <a href="https://twitter.com/BenFennell_NFL/status/1506638572874612743?ref_src=twsrc%5Etfw">March 23, 2022</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="KhBYhZ"><strong>DB Ja’Quan McMillan - East Carolina</strong></h2>
<blockquote><p id="ToUd01">McMillian is undersized and has only average speed, but he is an aggressive competitor with terrific instincts, eye use and ball skills. He projects best in the nickel.</p></blockquote>
<p id="iKmbFR"><a href="https://go.redirectingat.com?id=66960X1641777&amp;xs=1&amp;url=https%3A%2F%2Ftheathletic.com%2F3233612%2F2022%2F04%2F07%2F2022-nfl-draft-guide-the-beast-dane-brugler%2F%3Fsource%3Ddailyemail%26campaign%3D601983&amp;referrer=sbnation.com&amp;sref=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" rel="sponsored nofollow noopener" target="_blank" has-subtag="true" data-cdata='{"rewritten_url":"https://go.redirectingat.com?xcust=___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder\u0026id=66960X1641777\u0026xs=1\u0026url=https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983\u0026referrer=sbnation.com\u0026sref=https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","subtag_max_length":50,"subtag_delim_length":3,"subtag_key":"xcust","subtag_data":{"xcust":"___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder","id":"66960X1641777","xs":"1","url":"https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983","referrer":"sbnation.com","sref":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"},"encode_subtag":false}'>- Dane Brugler </a></p>
<blockquote><p id="q1Wuhc">McMillian projects as a versatile player at the next level. Although he can not hold up as an outside corner, he has the skills to play in the slot as well as at safety. Due to his foot quickness, instincts, and competitiveness, McMillian wins enough reps to allow him to stay on the field, giving him the opportunity to create turnovers. He is a developing player with good physical tools, an aggressive mentality, and a gift for taking the ball away. His size will limit his effectiveness on special teams, but he has the athleticism and attitude to contribute.</p></blockquote>
<p id="Og9Y8C"><a href="https://nfldraft.sportsinfosolutions.com/prospect/jaquan-mcmillian">- Ben Hrkach</a></p>
<div id="9Zh8X6">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr">Ja'Quan McMillan and DJ Ford at ECU Pro Day <a href="https://t.co/2KSd9eXKXN">pic.twitter.com/2KSd9eXKXN</a></p>— Clip -The Future- Brock (@tweetingclip) <a href="https://twitter.com/tweetingclip/status/1508820531168038912?ref_src=twsrc%5Etfw">March 29, 2022</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="UklYoL">
<strong>RB Isaih Pacheco - </strong><a href="https://www.onthebanks.com"><strong>Rutgers</strong></a>
</h2>
<blockquote><p id="39bwwg">Pacheco is a fast, energetic runner with the toughness and pass-blocking upside to stick in the NFL, but he needs to add patience and pace to his run diet and play with better control to have a chance at a pro career.</p></blockquote>
<p id="Ff1A9O"><a href="https://go.redirectingat.com?id=66960X1641777&amp;xs=1&amp;url=https%3A%2F%2Ftheathletic.com%2F3233612%2F2022%2F04%2F07%2F2022-nfl-draft-guide-the-beast-dane-brugler%2F%3Fsource%3Ddailyemail%26campaign%3D601983&amp;referrer=sbnation.com&amp;sref=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" rel="sponsored nofollow noopener" target="_blank" has-subtag="true" data-cdata='{"rewritten_url":"https://go.redirectingat.com?xcust=___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder\u0026id=66960X1641777\u0026xs=1\u0026url=https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983\u0026referrer=sbnation.com\u0026sref=https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","subtag_max_length":50,"subtag_delim_length":3,"subtag_key":"xcust","subtag_data":{"xcust":"___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder","id":"66960X1641777","xs":"1","url":"https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983","referrer":"sbnation.com","sref":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"},"encode_subtag":false}'>- Dane Brugler </a></p>
<blockquote><p id="Keb6kN">Pacheco projects to be a nice change-of-pace option to a running back room in the NFL. He’ll need to improve his run tempo regardless of his scheme, but he currently projects more comfortably to gap schemes that allow for quick hitting runs. He was also often given jet sweep handoffs and pitches to the outside, which got him into his preferred open-field spaces. He has the ability to contribute on 3rd down with his speed and toughness, but he’ll need to improve his stoutness in pass pro and consistency as a receiver to see more regular usage. He was a good kickoff returner his freshman season but hasn’t seen special teams duties since. He is a good candidate to return to that role in the NFL, and his physical profile also projects well to other units.</p></blockquote>
<p id="Ka4kYF">-<a href="https://nfldraft.sportsinfosolutions.com/prospect/isaih-pacheco"> John Todd &amp; Kendall Mirsky</a></p>
<div id="t2cZw7">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr"><a href="https://twitter.com/hashtag/Rutgers?src=hash&amp;ref_src=twsrc%5Etfw">#Rutgers</a> RB Isaih Pacheco is the late round RB most teams should be eyeing to add to a committee. Built like a brick house. Was one of the best players at both the Hula Bowl and East-West Shrine Bowl.</p>— Jordan Reid (@Jordan_Reid) <a href="https://twitter.com/Jordan_Reid/status/1499926123446210560?ref_src=twsrc%5Etfw">March 5, 2022</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="E4MPSw"><strong>TE Cole Turner - Nevada</strong></h2>
<blockquote><p id="ic6N5H">Turner is limited as a blocker, but skilled as a pass-catcher because of his ball skills and body control to easily expand his catch radius. He can be a poor man’s Mike Gesicki in the NFL, although his one-dimensional skill set will limit his landing spots.</p></blockquote>
<p id="KWOpXh"><a href="https://go.redirectingat.com?id=66960X1641777&amp;xs=1&amp;url=https%3A%2F%2Ftheathletic.com%2F3233612%2F2022%2F04%2F07%2F2022-nfl-draft-guide-the-beast-dane-brugler%2F%3Fsource%3Ddailyemail%26campaign%3D601983&amp;referrer=sbnation.com&amp;sref=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" rel="sponsored nofollow noopener" target="_blank" has-subtag="true" data-cdata='{"rewritten_url":"https://go.redirectingat.com?xcust=___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder\u0026id=66960X1641777\u0026xs=1\u0026url=https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983\u0026referrer=sbnation.com\u0026sref=https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","subtag_max_length":50,"subtag_delim_length":3,"subtag_key":"xcust","subtag_data":{"xcust":"___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder","id":"66960X1641777","xs":"1","url":"https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983","referrer":"sbnation.com","sref":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"},"encode_subtag":false}'>- Dane Brugler </a></p>
<blockquote><p id="disR6D">Turner projects as an H-tight end who fits best off the ball or in the slot, utilizing his best traits in passing situations. He has the ability to be a tough matchup cover on 3rd downs, but still needs to keep improving his route running ability to be able to separate more often mid-route. His struggles as a blocker make it tough for him to be counted on as a run blocker on 1st or 2nd down, though he can at least wall defenders off in pass pro for a couple of seconds if needed. He has the physical ability and athleticism to play on some special teams units, but also doesn’t show he really embraces that aspect of the game either.</p></blockquote>
<p id="yP666b"><a href="https://nfldraft.sportsinfosolutions.com/prospect/cole-turner">- Lucas Reimink</a></p>
<div id="5L1SZC">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr"><a href="https://twitter.com/hashtag/Nevada?src=hash&amp;ref_src=twsrc%5Etfw">#Nevada</a> TE Cole Turner and goal line fades. Name a better duo!<br><br>Seriously, he’s a weapon in the red zone. Boxes out defenders like a post player in basketball and has a nice catch radius, able to contort his body in many different ways. <a href="https://t.co/GYyt2JZ0gl">pic.twitter.com/GYyt2JZ0gl</a></p>— Devin Jackson (@RealD_Jackson) <a href="https://twitter.com/RealD_Jackson/status/1475104112400236544?ref_src=twsrc%5Etfw">December 26, 2021</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="WYJRlQ"><strong>DB Nick Grant - Virginia</strong></h2>
<blockquote><p id="jSHaH6">Grant projects as a backup free safety in a 2-high zone scheme where he can use his instincts, athleticism, and speed on passing downs and 3rd downs. While he did play most of his snaps at corner in college, his skill set fits better on the back end with the occasional chance he gets to work back down into the slot against tight ends. He will be a special teams contributor because of his speed and athleticism, but his lack of physicality may hinder where and how much he contributes.</p></blockquote>
<p id="8i5jGh"><a href="https://nfldraft.sportsinfosolutions.com/prospect/nick-grant">- Max Nuscher</a></p>
<div id="IgPloc">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr">Awesome rep here from Virginia cornerback Nick Grant. Really smooth short area COD for a defensive back 6’+. Doesn’t get talked about much but there are tools to work with there. <a href="https://t.co/0BkDOqnM70">pic.twitter.com/0BkDOqnM70</a></p>— Ryan Roberts (@RiseNDraft) <a href="https://twitter.com/RiseNDraft/status/1339238548826959876?ref_src=twsrc%5Etfw">December 16, 2020</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="XkfoYr"><strong>QB/WR - D’Eriq King - Miami (FL)</strong></h2>
<blockquote><p id="ulYEP8">King is undersized, and his history of injuries is concerning, but he has exciting athleticism to make the transition to wide receiver while also contributing in the backfield with his ball-handling skills.</p></blockquote>
<p id="FzSpbJ"><a href="https://go.redirectingat.com?id=66960X1641777&amp;xs=1&amp;url=https%3A%2F%2Ftheathletic.com%2F3233612%2F2022%2F04%2F07%2F2022-nfl-draft-guide-the-beast-dane-brugler%2F%3Fsource%3Ddailyemail%26campaign%3D601983&amp;referrer=sbnation.com&amp;sref=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" rel="sponsored nofollow noopener" target="_blank" has-subtag="true" data-cdata='{"rewritten_url":"https://go.redirectingat.com?xcust=___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder\u0026id=66960X1641777\u0026xs=1\u0026url=https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983\u0026referrer=sbnation.com\u0026sref=https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","subtag_max_length":50,"subtag_delim_length":3,"subtag_key":"xcust","subtag_data":{"xcust":"___sb__p_22779148__m_m-placeholder__s_s-placeholder__t_w__c_c-placeholder__r_r-placeholder__d_d-placeholder","id":"66960X1641777","xs":"1","url":"https://theathletic.com/3233612/2022/04/07/2022-nfl-draft-guide-the-beast-dane-brugler/?source=dailyemail\u0026campaign=601983","referrer":"sbnation.com","sref":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"},"encode_subtag":false}'>- Dane Brugler </a></p>
<div id="PlOD1L">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr">Miami HC Manny Diaz announced D’Eriq King opted to have season-ending surgery…<br><br>King: <a href="https://t.co/rNWLoxhOdv">pic.twitter.com/rNWLoxhOdv</a></p>— PFF Draft (@PFF_College) <a href="https://twitter.com/PFF_College/status/1447578906115063820?ref_src=twsrc%5Etfw">October 11, 2021</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<p id="9fRRH2"><strong>Two final notes:</strong> After doing some digging I did not find a single scouting report on QB/WR/KR Jared Bernhardt and running back Shermari Jones. Bernhardt is a former lacrosse player who played QB for D2 power Ferris State. He’s expected to try and make it in the NFL as a receiver, but ran a 4.7 40 at 6’1 and 189 lbs. Jones is a 6’ 213 lb. running back from Coastal Carolina who finished his career with 247 touches for 1475 yards and 16 touchdowns. Odds are the Broncos brought them both in for a visit to recruit them for after the draft. </p>
<div id="GrsB5e">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr">Shermari Jones is a RB prospect in the 2022 draft class. He scored a 6.66 RAS out of a possible 10.00. This ranked 531 out of 1589 RB from 1987 to 2022. <a href="https://t.co/RW1NcUAg1n">https://t.co/RW1NcUAg1n</a> <a href="https://twitter.com/hashtag/RAS?src=hash&amp;ref_src=twsrc%5Etfw">#RAS</a> <a href="https://t.co/qbhOKXHJoD">pic.twitter.com/qbhOKXHJoD</a></p>— Kent Lee Platte (@MathBomb) <a href="https://twitter.com/MathBomb/status/1511038388601712643?ref_src=twsrc%5Etfw">April 4, 2022</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="KCiixA"><strong>Your Broncos’ News</strong></h2>
<h4 id="ksJdcC"><a href="https://www.milehighreport.com/2022/4/8/23016805/rob-walton-bid-broncos-4-billion">Rob Walton to submit bid on Denver Broncos north of $4 billion - Mile High Report</a></h4>
<blockquote><p id="3CiXB7">Rob Walton, of Walmart, intends to submit a huge bid on the Denver Broncos on Friday that will make him an immediate favorite to purchase the franchise.</p></blockquote>
<h4 id="g6vGC3"><a href="https://profootballtalk.nbcsports.com/2022/04/08/rob-walton-cousin-by-marriage-of-stan-kroenke-prepares-to-bid-on-the-broncos/">Rob Walton, cousin by marriage of Stan Kroenke, prepares to bid on the Broncos - ProFootballTalk</a></h4>
<blockquote><p id="UoTLJi">“A bid needs to have a four in front of it,” a source close to the process told the Post. At an estimated worth of $70 billion, Walton presumably can offer more than anyone else, which would be enough to secure the team. Although the league reportedly had hoped that the team would be sold to a group led by a minority, the Broncos currently are held in trust — and the trustees have a fiduciary duty to maximize the return. The final price, per the Post, is expected to land between $4.5 billion and $5 billion.</p></blockquote>
<h4 id="U3b2kp"><a href="https://www.milehighreport.com/2022/4/7/23015775/report-broncos-re-sign-kareem-jackson-to-one-year-deal">Report: Broncos re-sign Kareem Jackson to one-year deal - Mile High Report</a></h4>
<blockquote><p id="MPkxuU">The veteran safety will return for year four in Denver.</p></blockquote>
<h4 id="xgFIyJ"><a href="https://www.milehighreport.com/2022/4/8/23015026/broncos-remaining-needs-2022-nfl-draft">Do the Denver Broncos have any remaining needs going into NFL Draft? - Mile High Report</a></h4>
<blockquote><p id="W6LV4v">AJ Schulte and Joe Rowles discuss on this week’s Cover 2 Broncos.</p></blockquote>
<h4 id="GnFpKO"><a href="https://www.milehighreport.com/2022/4/8/23015019/nfl-heaviest-of-the-heavy-on-offensive-line">The heaviest of the heavy on the NFL offensive line - Mile High Report</a></h4>
<blockquote><p id="zbbkXL">A look at the NFL careers, or lack thereof, for the heaviest guards and tackles from the <a href="https://www.sbnation.com/nfl-combine">NFL combine</a> 2000-2022</p></blockquote>
<h4 id="wMSbQs"><a href="https://www.milehighreport.com/2022/4/8/23010056/2022-nfl-draft-profile-abraham-lucas">2022 NFL Draft Profile: Washington State Offensive Tackle Abraham Lucas - Mile High Report</a></h4>
<blockquote><p id="Rb0Tan">Could Abraham Lucas be the Broncos’ right tackle of the future?</p></blockquote>
<h4 id="syKQK5"><a href="https://www.milehighreport.com/2022/4/4/23009323/2022-nfl-draft-denver-broncos-draft-interest-tracker">2022 NFL Draft: Denver Broncos draft interest tracker - Mile High Report</a></h4>
<blockquote><p id="3l9b3j">What prospects have the Denver Broncos been showing interest in</p></blockquote>
<h4 id="fumFZB"><a href="https://www.espn.com/nfl/story/_/id/33690172/steve-wilks-ray-horton-join-brian-flores-lawsuit-nfl-teams-alleging-racism-hiring-practices">Steve Wilks, Ray Horton join Brian Flores’ lawsuit against NFL, teams, in alleging racism in hiring practices</a></h4>
<blockquote><p id="Vk0RQr">Steve Wilks, who was the <a href="https://www.revengeofthebirds.com/">Arizona Cardinals</a>’ head coach for one season in 2018, and Ray Horton, an NFL assistant since 1994 who interviewed for the <a href="https://www.musiccitymiracles.com/">Tennessee Titans</a>’ head-coaching job in 2016, are now part of the lawsuit filed against the league, the <a href="https://www.thephinsider.com/">Dolphins</a>, the Denver Broncos, the <a href="https://www.bigblueview.com/">New York Giants</a>, the <a href="https://www.battleredblog.com/">Houston Texans</a>, the Titans and the Cardinals, plus 26 other “John Doe” NFL teams. The Titans, Cardinals and Texans were added to the suit as part of the amendment as well.</p></blockquote>
<div id="jr2lcG">
<blockquote class="twitter-tweet">
<p lang="en" dir="ltr">According to <a href="https://twitter.com/JayGlazer?ref_src=twsrc%5Etfw">@JayGlazer</a> the Broncos have worked out former Viking and Giant Kyle Rudolph.</p>— Joe Rowles (@JoRo_NFL) <a href="https://twitter.com/JoRo_NFL/status/1512569389064892422?ref_src=twsrc%5Etfw">April 8, 2022</a>
</blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
<h2 id="RbyiIu"><a href="http://www.sbnation.com/nfl-news"><strong>NFL News</strong></a></h2>
<h4 id="LKK1Ms"><a href="https://www.nfl.com/news/ravens-engaging-in-talks-with-free-agent-rb-melvin-gordon">Ravens engaging in talks with free-agent RB Melvin Gordon</a></h4>
<blockquote><p id="KC7vPw">Gordon is just a few years removed from having enough performance-based leverage to demand a pay raise (or trade) from the <a href="https://www.boltsfromtheblue.com/">Chargers</a>, who ultimately let him walk in free agency following a 2019 season that began with a holdout. Gordon didn’t venture far when finding a new team, signing a two-year, $16 million deal with the AFC West rival Denver Broncos.</p></blockquote>
<h4 id="wiFfxC"><a href="https://profootballtalk.nbcsports.com/2022/04/08/melvin-gordon-talking-to-ravens-about-contract/">Report: Melvin Gordon talking to Ravens about contract - ProFootballTalk</a></h4>
<blockquote><p id="yJlkpK">Gordon ran 203 times for 918 yards and eight touchdowns with the Broncos last season. There was word of a possible return to Denver last month, but Gordon recently changed agents as part of his continued search for a new team.</p></blockquote>
<h4 id="u2FUiX"><a href="https://www.nfl.com/news/tyrann-mathieu-heartbroken-over-leaving-chiefs-after-three-seasons-in-kansas-cit">Tyrann Mathieu ‘heartbroken’ over leaving Chiefs after three seasons in Kansas City</a></h4>
<blockquote><p id="IX7HJv">“To be honest, if they would’ve offered me Justin Reid’s deal, obviously I would’ve tried to negotiate, but if that’s where they drew their line in the sand, I probably would’ve took it,” Mathieu said. “I probably would’ve took it. Agents are going to do their thing, but at the end of the day, it’s the player’s decision whether to sign it or not.”</p></blockquote>
<h4 id="YOYe1U"><a href="https://www.theringer.com/nfl/2022/4/7/23014731/new-york-giants-daniel-jones-question-fifth-year-option">How Will the Giants Answer Their Daniel Jones Question? - The Ringer</a></h4>
<blockquote><p id="kBrwpF">Having drafted Jones 35 months ago, the Giants’ evaluation period is just about up. They have until May 2, the first Monday after the draft, to pick up Jones’s fifth-year option, which would lock him in for a fully guaranteed salary of about $22.4 million for 2023.</p></blockquote>
  
</div>



<div class="u-hidden-text" id="formatter-datter" data-cid="site/entry_formatter-1649516448_1590_358054" data-cdata='{"svg_hr_illustration":""}'>
  
</div>






    <section class="c-nextclick">
  <div class="c-related-list" data-cid="site/related_list-1649516448_6637_358055" data-cdata="{}">
  <h2 class="c-related-list__head">
    More From
    
        <span class="c-related-list__community-name">Mile High Report</span>
    
  </h2>
  <ul>
    
      <li>
        
        
          <a data-analytics-link="nextclicks" data-analytics-viewport="nextclicks" data-vars-analytics-link-title="Report: Broncos worked out veteran tight end Kyle Rudolph" href="https://www.milehighreport.com/2022/4/8/23017402/report-broncos-worked-out-veteran-tight-end-kyle-rudolph">Report: Broncos worked out veteran tight end Kyle Rudolph</a>
        
      </li>
    
      <li>
        
        
          <a data-analytics-link="nextclicks" data-analytics-viewport="nextclicks" data-vars-analytics-link-title="Report: Rob Walton to submit bid on Broncos north of $4 billion" href="https://www.milehighreport.com/2022/4/8/23016805/rob-walton-bid-broncos-4-billion">Report: Rob Walton to submit bid on Broncos north of $4 billion</a>
        
      </li>
    
      <li>
        
        
          <a data-analytics-link="nextclicks" data-analytics-viewport="nextclicks" data-vars-analytics-link-title="Is there a place in the NFL for the heaviest of the heavy on the offensive line?" href="https://www.milehighreport.com/2022/4/8/23015019/nfl-heaviest-of-the-heavy-on-offensive-line">Is there a place in the NFL for the heaviest of the heavy on the offensive line?</a>
        
      </li>
    
      <li>
        
        
          <a data-analytics-link="nextclicks" data-analytics-viewport="nextclicks" data-vars-analytics-link-title="With Kareem Jackson signed, do the Broncos have any remaining needs going into the NFL Draft?" href="https://www.milehighreport.com/2022/4/8/23015026/broncos-remaining-needs-2022-nfl-draft">With Kareem Jackson signed, do the Broncos have any remaining needs going into the NFL Draft?</a>
        
      </li>
    
      <li>
        
        
          <a data-analytics-link="nextclicks" data-analytics-viewport="nextclicks" data-vars-analytics-link-title="2022 NFL Draft Profile: Washington State OT Abraham Lucas" href="https://www.milehighreport.com/2022/4/8/23010056/2022-nfl-draft-profile-abraham-lucas">2022 NFL Draft Profile: Washington State OT Abraham Lucas</a>
        
      </li>
    
      <li>
        
        
          <a data-analytics-link="nextclicks" data-analytics-viewport="nextclicks" data-vars-analytics-link-title="McShay Mock Draft sends 390-pound tackle to Broncos" href="https://www.milehighreport.com/2022/4/8/23016009/mcshay-mock-draft-sends-390-pound-tackle-to-broncos">McShay Mock Draft sends 390-pound tackle to Broncos</a>
        
      </li>
    
    <div>
  <div class="m-native_ad_unit dynamic-native-ad-native_ad_linkset_link"></div>
</div>

  </ul>
  
    <div class="c-related-list__video">
      
        
  <div class="c-video-embed--media">
    <iframe frameborder="no" src="https://playlist.megaphone.fm?p=VMP5886242405" width="100%" height="482"></iframe>
  </div>




      
    </div>
  
</div>

</section>

  </div>
    <div class="l-col__sidebar" data-analytics-placement="sidebar">
        
  
      <div class="u-desktop-only">
        <aside class="c-rock-list c-rock-list--image c-rock-list--trending" id="rock-">
  <h3 class="p-rock-head c-rock-list__title">
    <svg version="1.1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 300 50" style="enable-background:new 0 0 300 50;"><g><polygon points="31.1,0 26.1,0 21.7,3.2 35.7,46.2 -0.1,20.1 -0.1,23.7 36,50 40,50 25.1,4.3 	"></polygon><polygon points="14.7,0.9 15.9,0 11.3,0 18.7,22.8 -0.1,9.1 -0.1,12.7 24.2,30.4 	"></polygon><polygon points="106.9,0 102,0 74.1,20.2 83.8,50 86.8,50 77.5,21.3 	"></polygon><polygon points="-0.1,34.7 20.9,50 25.8,50 -0.1,31.2 	"></polygon><polygon points="-0.1,42.2 -0.1,45.8 5.7,50 10.6,50 	"></polygon><polygon points="76.6,0 71.6,0 53.2,13.4 65,50 68.1,50 56.6,14.5 	"></polygon><polygon points="91.7,0 86.8,0 63.6,16.8 74.4,50 77.5,50 67,17.9 	"></polygon><polygon points="61.4,0 56.5,0 42.7,10 55.7,50 58.7,50 46.1,11.1 	"></polygon><polygon points="46.2,0 41.3,0 32.2,6.6 46.3,50 49.3,50 35.6,7.7 	"></polygon></g></svg>

    
    <span class="c-rock-list__title-wrapper">
      
        <span class="c-rock-list__title-text">
          Most Read
        </span>
      
    </span>
  </h3>
  <div class="c-rock-list__body">
    
    <ol class="c-rock-list__items">
    
      
        <li class="c-rock-list__item" data-analytics-placement="sidebar:1">
      
        <a href="https://www.milehighreport.com/2022/4/8/23016805/rob-walton-bid-broncos-4-billion" class="c-rock-list__link" data-analytics-link="trending" data-analytics-viewport="trending" data-chorus-optimize-id="22780846" data-chorus-optimize-module="entry-list">
          
            <div class="c-rock-list__image">
              
                <picture class="c-picture" data-chorus-optimize-field="main_image" data-cid="site/picture_element-1649513986_9738_277526" data-cdata='{"image_id":70727319,"ratio":"standard","dynamic_type":"picture","lazy":true}'>
  <script type="text/template-picture" style="display: none;">
    


  <source
    srcset="https://cdn.vox-cdn.com/thumbor/U8n_zVsDokrJikoVoWlds2HYXZg=/0x0:3500x2246/250x167/filters:focal(1485x492:2045x1052):format(webp)/cdn.vox-cdn.com/uploads/chorus_image/image/70727319/965568292.0.jpg 250w, https://cdn.vox-cdn.com/thumbor/rkOp-4L3q4m8d8TKyUxVZ6LqHsY=/0x0:3500x2246/500x333/filters:focal(1485x492:2045x1052):format(webp)/cdn.vox-cdn.com/uploads/chorus_image/image/70727319/965568292.0.jpg 500w"
    sizes="250px"
    type="image/webp"
  >


<img srcset="https://cdn.vox-cdn.com/thumbor/z3IxOJR-ZhsLAGrN8RKME3VZGhc=/0x0:3500x2246/250x167/filters:focal(1485x492:2045x1052)/cdn.vox-cdn.com/uploads/chorus_image/image/70727319/965568292.0.jpg 250w, https://cdn.vox-cdn.com/thumbor/9f02MGofgU_BkIkHe7oEYmO3CcY=/0x0:3500x2246/500x333/filters:focal(1485x492:2045x1052)/cdn.vox-cdn.com/uploads/chorus_image/image/70727319/965568292.0.jpg 500w" sizes="250px" alt="Walmart Holds Annual Multi-Day Shareholders Meeting In Arkansas" data-upload-width="3500" src="https://cdn.vox-cdn.com/thumbor/lJKtAGgZ3sG15kwfdiK6twpqd5I=/0x0:3500x2246/1200x800/filters:focal(1485x492:2045x1052)/cdn.vox-cdn.com/uploads/chorus_image/image/70727319/965568292.0.jpg" />

  </script>
  <script type="text/template-dynamic" style="display: none">
    
<img class="c-dynamic-image " alt="Walmart Holds Annual Multi-Day Shareholders Meeting In Arkansas" data-chorus-optimize-field="main_image" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs" data-cid="site/dynamic_size_image-1649513986_7962_277525" data-cdata='{"image_id":70727319,"ratio":"standard"}'>
<noscript><img alt="Walmart Holds Annual Multi-Day Shareholders Meeting In Arkansas" src="https://cdn.vox-cdn.com/uploads/chorus_image/image/70727319/965568292.0.jpg"></noscript>

  </script>
</picture>

              
            </div>
          
          <span class="c-rock-list__item--body">
            
            <span data-chorus-optimize-field="hed">Report: Rob Walton to submit bid on Broncos north of $4 billion</span>
            
              <span class="c-rock-list__entry-blurb">Rob Walton, of Walmart, intends to submit a huge bid on the Denver Broncos on Friday that will make him an immediate favorite to purchase the franchise.</span>
            
          </span>
        </a>
        
        
      </li>
    
      
        <li class="c-rock-list__item" data-analytics-placement="sidebar:2">
      
        <a href="https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" class="c-rock-list__link" data-analytics-link="trending" data-analytics-viewport="trending" data-chorus-optimize-id="22779148" data-chorus-optimize-module="entry-list">
          
            <div class="c-rock-list__image">
              
                <picture class="c-picture" data-chorus-optimize-field="main_image" data-cid="site/picture_element-1649513986_2600_277528" data-cdata='{"image_id":70729700,"ratio":"standard","dynamic_type":"picture","lazy":true}'>
  <script type="text/template-picture" style="display: none;">
    


  <source
    srcset="https://cdn.vox-cdn.com/thumbor/YGjsSudc2sYHM5u3IEjkvddi1Ys=/0x0:4908x3487/250x167/filters:focal(1492x1085:2276x1869):format(webp)/cdn.vox-cdn.com/uploads/chorus_image/image/70729700/1238931000.0.jpg 250w, https://cdn.vox-cdn.com/thumbor/qS_-wAX11-b7BoRN0JwGDeH4YTk=/0x0:4908x3487/500x333/filters:focal(1492x1085:2276x1869):format(webp)/cdn.vox-cdn.com/uploads/chorus_image/image/70729700/1238931000.0.jpg 500w"
    sizes="250px"
    type="image/webp"
  >


<img srcset="https://cdn.vox-cdn.com/thumbor/OEvaWI6B5W7ObOn8Ucdo_CX8Daw=/0x0:4908x3487/250x167/filters:focal(1492x1085:2276x1869)/cdn.vox-cdn.com/uploads/chorus_image/image/70729700/1238931000.0.jpg 250w, https://cdn.vox-cdn.com/thumbor/4xhZLWy8iwj8994_0CDLCNUyfAM=/0x0:4908x3487/500x333/filters:focal(1492x1085:2276x1869)/cdn.vox-cdn.com/uploads/chorus_image/image/70729700/1238931000.0.jpg 500w" sizes="250px" alt="NFL Combine" data-upload-width="4908" src="https://cdn.vox-cdn.com/thumbor/nHRoH3fNwyZC-hRC2b7PDTPaD00=/0x0:4908x3487/1200x800/filters:focal(1492x1085:2276x1869)/cdn.vox-cdn.com/uploads/chorus_image/image/70729700/1238931000.0.jpg" />

  </script>
  <script type="text/template-dynamic" style="display: none">
    
<img class="c-dynamic-image " alt="NFL Combine" data-chorus-optimize-field="main_image" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs" data-cid="site/dynamic_size_image-1649513986_8345_277527" data-cdata='{"image_id":70729700,"ratio":"standard"}'>
<noscript><img alt="NFL Combine" src="https://cdn.vox-cdn.com/uploads/chorus_image/image/70729700/1238931000.0.jpg"></noscript>

  </script>
</picture>

              
            </div>
          
          <span class="c-rock-list__item--body">
            
            <span data-chorus-optimize-field="hed">What do NFL Draft analysts say about the Broncos’ top 30 NFL Draft visits thus far?</span>
            
              <span class="c-rock-list__entry-blurb">We know half of the Broncos’ official 30 visits. What do they tell us about Paton’s plan for draft day?</span>
            
          </span>
        </a>
        
        
      </li>
    
      
        <li class="c-rock-list__item" data-analytics-placement="sidebar:3">
      
        <a href="https://www.milehighreport.com/2022/4/8/23017402/report-broncos-worked-out-veteran-tight-end-kyle-rudolph" class="c-rock-list__link" data-analytics-link="trending" data-analytics-viewport="trending" data-chorus-optimize-id="22781443" data-chorus-optimize-module="entry-list">
          
            <div class="c-rock-list__image">
              
                <picture class="c-picture" data-chorus-optimize-field="main_image" data-cid="site/picture_element-1649513986_49_277530" data-cdata='{"image_id":70729005,"ratio":"standard","dynamic_type":"picture","lazy":true}'>
  <script type="text/template-picture" style="display: none;">
    


  <source
    srcset="https://cdn.vox-cdn.com/thumbor/_iEjue8qFW_3r8PaTFgsLW20fnk=/0x0:3375x2250/250x167/filters:focal(1055x185:1595x725):format(webp)/cdn.vox-cdn.com/uploads/chorus_image/image/70729005/1236207055.0.jpg 250w, https://cdn.vox-cdn.com/thumbor/jZg3IZrDxmLRRTPLxyjbdac0CZE=/0x0:3375x2250/500x333/filters:focal(1055x185:1595x725):format(webp)/cdn.vox-cdn.com/uploads/chorus_image/image/70729005/1236207055.0.jpg 500w"
    sizes="250px"
    type="image/webp"
  >


<img srcset="https://cdn.vox-cdn.com/thumbor/dSTqohFr_741MWikatRPKYHC0tE=/0x0:3375x2250/250x167/filters:focal(1055x185:1595x725)/cdn.vox-cdn.com/uploads/chorus_image/image/70729005/1236207055.0.jpg 250w, https://cdn.vox-cdn.com/thumbor/yiRgewTHvla_x8Wi9QxOWW_0Vdo=/0x0:3375x2250/500x333/filters:focal(1055x185:1595x725)/cdn.vox-cdn.com/uploads/chorus_image/image/70729005/1236207055.0.jpg 500w" sizes="250px" alt="Carolina Panthers v New York Giants" data-upload-width="3375" src="https://cdn.vox-cdn.com/thumbor/nlND-XKQgfAJiAkj2iCyHzKN1x4=/0x0:3375x2250/1200x800/filters:focal(1055x185:1595x725)/cdn.vox-cdn.com/uploads/chorus_image/image/70729005/1236207055.0.jpg" />

  </script>
  <script type="text/template-dynamic" style="display: none">
    
<img class="c-dynamic-image " alt="Carolina Panthers v New York Giants" data-chorus-optimize-field="main_image" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs" data-cid="site/dynamic_size_image-1649513986_6711_277529" data-cdata='{"image_id":70729005,"ratio":"standard"}'>
<noscript><img alt="Carolina Panthers v New York Giants" src="https://cdn.vox-cdn.com/uploads/chorus_image/image/70729005/1236207055.0.jpg"></noscript>

  </script>
</picture>

              
            </div>
          
          <span class="c-rock-list__item--body">
            
            <span data-chorus-optimize-field="hed">Report: Broncos worked out veteran tight end Kyle Rudolph</span>
            
              <span class="c-rock-list__entry-blurb">The veteran tight end is getting a look from the Broncos.</span>
            
          </span>
        </a>
        
        
      </li>
    
      
        <li class="c-rock-list__item" data-analytics-placement="sidebar:4">
      
        <a href="https://www.milehighreport.com/2022/4/8/23015026/broncos-remaining-needs-2022-nfl-draft" class="c-rock-list__link" data-analytics-link="trending" data-analytics-viewport="trending" data-chorus-optimize-id="22779067" data-chorus-optimize-module="entry-list">
          
            <div class="c-rock-list__image">
              
                <picture class="c-picture" data-chorus-optimize-field="main_image" data-cid="site/picture_element-1649513986_8568_277532" data-cdata='{"image_id":70725700,"ratio":"standard","dynamic_type":"picture","lazy":true}'>
  <script type="text/template-picture" style="display: none;">
    


  <source
    srcset="https://cdn.vox-cdn.com/thumbor/Fk9kvZVLwxGFJjJLDyqgV_0mMTo=/0x0:3000x2000/250x167/filters:focal(1221x499:1701x979):format(webp)/cdn.vox-cdn.com/uploads/chorus_image/image/70725700/1341460652.0.jpg 250w, https://cdn.vox-cdn.com/thumbor/IOZXB4ZNqnOCLbj55CvMK882k-Y=/0x0:3000x2000/500x333/filters:focal(1221x499:1701x979):format(webp)/cdn.vox-cdn.com/uploads/chorus_image/image/70725700/1341460652.0.jpg 500w"
    sizes="250px"
    type="image/webp"
  >


<img srcset="https://cdn.vox-cdn.com/thumbor/9iUzc_2KoFeTIvbLYJnyHLEZdls=/0x0:3000x2000/250x167/filters:focal(1221x499:1701x979)/cdn.vox-cdn.com/uploads/chorus_image/image/70725700/1341460652.0.jpg 250w, https://cdn.vox-cdn.com/thumbor/JOwuQPvzOIv1JUF4nCPGDntr7mE=/0x0:3000x2000/500x333/filters:focal(1221x499:1701x979)/cdn.vox-cdn.com/uploads/chorus_image/image/70725700/1341460652.0.jpg 500w" sizes="250px" alt="Denver Broncos v New York Giants" data-upload-width="3000" src="https://cdn.vox-cdn.com/thumbor/IEFfCTpukxeThC99lmuYP-p6THI=/0x0:3000x2000/1200x800/filters:focal(1221x499:1701x979)/cdn.vox-cdn.com/uploads/chorus_image/image/70725700/1341460652.0.jpg" />

  </script>
  <script type="text/template-dynamic" style="display: none">
    
<img class="c-dynamic-image " alt="Denver Broncos v New York Giants" data-chorus-optimize-field="main_image" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs" data-cid="site/dynamic_size_image-1649513986_900_277531" data-cdata='{"image_id":70725700,"ratio":"standard"}'>
<noscript><img alt="Denver Broncos v New York Giants" src="https://cdn.vox-cdn.com/uploads/chorus_image/image/70725700/1341460652.0.jpg"></noscript>

  </script>
</picture>

              
            </div>
          
          <span class="c-rock-list__item--body">
            
            <span data-chorus-optimize-field="hed">With Kareem Jackson signed, do the Broncos have any remaining needs going into the NFL Draft?</span>
            
              <span class="c-rock-list__entry-blurb">AJ Schulte and Joe Rowles discuss on this week’s Cover 2 Broncos.</span>
            
          </span>
        </a>
        
        
      </li>
    
      
        <li class="c-rock-list__item" data-analytics-placement="sidebar:5">
      
        <a href="https://www.milehighreport.com/2022/4/8/23015019/nfl-heaviest-of-the-heavy-on-offensive-line" class="c-rock-list__link" data-analytics-link="trending" data-analytics-viewport="trending" data-chorus-optimize-id="22779060" data-chorus-optimize-module="entry-list">
          
            <div class="c-rock-list__image">
              
                <picture class="c-picture" data-chorus-optimize-field="main_image" data-cid="site/picture_element-1649513986_3622_277534" data-cdata='{"image_id":70726473,"ratio":"standard","dynamic_type":"picture","lazy":true}'>
  <script type="text/template-picture" style="display: none;">
    


  <source
    srcset="https://cdn.vox-cdn.com/thumbor/Qi9Oe_RMUkV0xOs8UrKcodMGKdI=/0x0:1618x2422/250x167/filters:focal(830x543:1088x801):format(webp)/cdn.vox-cdn.com/uploads/chorus_image/image/70726473/usa_today_17441983.0.jpg 250w, https://cdn.vox-cdn.com/thumbor/oFEon9_28hsnSx7Pb9tJ-Ssq6cg=/0x0:1618x2422/500x333/filters:focal(830x543:1088x801):format(webp)/cdn.vox-cdn.com/uploads/chorus_image/image/70726473/usa_today_17441983.0.jpg 500w"
    sizes="250px"
    type="image/webp"
  >


<img srcset="https://cdn.vox-cdn.com/thumbor/6iaH7YOBCRqJtqlrnfx-cJd42eo=/0x0:1618x2422/250x167/filters:focal(830x543:1088x801)/cdn.vox-cdn.com/uploads/chorus_image/image/70726473/usa_today_17441983.0.jpg 250w, https://cdn.vox-cdn.com/thumbor/9EpCLNgketVV440P0A-3BbPxyYg=/0x0:1618x2422/500x333/filters:focal(830x543:1088x801)/cdn.vox-cdn.com/uploads/chorus_image/image/70726473/usa_today_17441983.0.jpg 500w" sizes="250px" alt="NCAA Football: Guaranteed Rate Bowl-Minnesota at West Virginia" data-upload-width="1618" src="https://cdn.vox-cdn.com/thumbor/CBpD0H68tgNBmsw3--thxVofBZE=/0x0:1618x2422/1200x800/filters:focal(830x543:1088x801)/cdn.vox-cdn.com/uploads/chorus_image/image/70726473/usa_today_17441983.0.jpg" />

  </script>
  <script type="text/template-dynamic" style="display: none">
    
<img class="c-dynamic-image " alt="NCAA Football: Guaranteed Rate Bowl-Minnesota at West Virginia" data-chorus-optimize-field="main_image" src="data:image/gif;base64,R0lGODlhAQABAIAAAAUEBAAAACwAAAAAAQABAAACAkQBADs" data-cid="site/dynamic_size_image-1649513986_3729_277533" data-cdata='{"image_id":70726473,"ratio":"standard"}'>
<noscript><img alt="NCAA Football: Guaranteed Rate Bowl-Minnesota at West Virginia" src="https://cdn.vox-cdn.com/uploads/chorus_image/image/70726473/usa_today_17441983.0.jpg"></noscript>

  </script>
</picture>

              
            </div>
          
          <span class="c-rock-list__item--body">
            
            <span data-chorus-optimize-field="hed">Is there a place in the NFL for the heaviest of the heavy on the offensive line?</span>
            
              <span class="c-rock-list__entry-blurb">A look at the NFL careers, or lack thereof, for the heaviest guards and tackles from the NFL combine 2000-2022</span>
            
          </span>
        </a>
        
        
      </li>
    
    </ol>
    <div>
  <div class="m-native_ad_unit dynamic-native-ad-native_ad_latest"></div>
</div>

  </div>
  
</aside>

  <script type="text/javascript">concertAdsQueue.push(function() {concertAds.addVariable("trending_sidebar", ["true"])});</script>


      </div>
      <div class="">
        <div class="metabet-adtile-auto metabet-size-300x300"></div>

      </div>


    </div>
</div>

  <div class="l-segment outbrain-container">
    <div class="OUTBRAIN" data-src="https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" data-widget-id="AR_10" data-ob-template="SBNation_1" ></div>

<script type="text/javascript" charset="utf-8">
(function(){
  // load outbrain js
  function loadOutbrain(){
    var ref = document.querySelector("div.OUTBRAIN");

    var script = document.createElement('script');
    script.setAttribute('type','text/javascript');
    script.setAttribute('src', 'https://widgets.outbrain.com/outbrain.js');
    script.setAttribute('async', 'async');

    ref.appendChild(script);
  }

  // Disable on mobile and tablet screens
  // 880px is the upper bound for the `medium` breakpoint defined in UserAgent JS lib.
  var shouldDisable = false && screen.width <= 880;
  var scrollSubscriber = document.cookie.indexOf("scroll0=") > -1;
  var hymnalPreviewContent = !!(window.location.href.indexOf("concert_preview") > -1);

  if (!shouldDisable && !scrollSubscriber && !hymnalPreviewContent) {
    // first, set a timeout to loadOutbrain, in case no ads load in 5s
    // (i.e., blocked). once an ad has loaded, create a new timeout that
    // will load outbrain if openmic doesn't get loaded in 2s
    //
    var adBlockerTimeoutId = setTimeout(loadOutbrain, 5000);
    document.body.addEventListener('first_ad_rendered', function(){
      clearTimeout(adBlockerTimeoutId);
      var outbrainTimeoutId = setTimeout(loadOutbrain, 2000);
      document.body.addEventListener('playlistRendered', function(){
        clearTimeout(outbrainTimeoutId);
      });
    });
  }
})();
</script>

  </div>

  <div class="l-segment outbrain-container">
    <div class="OUTBRAIN" data-src="https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" data-widget-id="AR_2" data-ob-template="SBNation_1" ></div>

<script type="text/javascript" charset="utf-8">
(function(){
  // load outbrain js
  function loadOutbrain(){
    var ref = document.querySelector("div.OUTBRAIN");

    var script = document.createElement('script');
    script.setAttribute('type','text/javascript');
    script.setAttribute('src', 'https://widgets.outbrain.com/outbrain.js');
    script.setAttribute('async', 'async');

    ref.appendChild(script);
  }

  // Disable on mobile and tablet screens
  // 880px is the upper bound for the `medium` breakpoint defined in UserAgent JS lib.
  var shouldDisable = false && screen.width <= 880;
  var scrollSubscriber = document.cookie.indexOf("scroll0=") > -1;
  var hymnalPreviewContent = !!(window.location.href.indexOf("concert_preview") > -1);

  if (!shouldDisable && !scrollSubscriber && !hymnalPreviewContent) {
    // first, set a timeout to loadOutbrain, in case no ads load in 5s
    // (i.e., blocked). once an ad has loaded, create a new timeout that
    // will load outbrain if openmic doesn't get loaded in 2s
    //
    var adBlockerTimeoutId = setTimeout(loadOutbrain, 5000);
    document.body.addEventListener('first_ad_rendered', function(){
      clearTimeout(adBlockerTimeoutId);
      var outbrainTimeoutId = setTimeout(loadOutbrain, 2000);
      document.body.addEventListener('playlistRendered', function(){
        clearTimeout(outbrainTimeoutId);
      });
    });
  }
})();
</script>

  </div>

<div class="l-sidebar-fixed l-segment">
  <div class="l-col__main">
      <div id="comments" data-cid="apps/coral-1649516448_38_358056" data-cdata='{"entry_url":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far","entry_id":22779148,"coral_root_url":"https://comments.milehighreport.com","coral_cache_version":"1626303173","coral_version":5,"lazy_load":true,"coral_css_url":"https://www.milehighreport.com/style/coral_fonts/55/index.css","recommended_threshold":7,"moderation_email":"moderation@sbnation.com"}'>
  <div id="coral_thread" class="c-comments">
    <div class="c-comments__header">
      <h4 class="c-comments__message">Loading comments...</h4>
    </div>
  </div>
</div>




  </div>
    <div class="l-col__sidebar" id="comments-sidebar" data-analytics-placement="sidebar">
      
    </div>
</div>

  </article>
</main>




    <footer class="c-footer c-footer__community" role="contentinfo" data-cid="site/global_footer-1649516412_9371_133840" data-cdata="{}">
  <div class="l-wrapper c-footer__wrapper">
    <div class="c-footer__section c-footer__section-logo">
      <a rel="nofollow" href="/" class="c-footer__logo-link">
        
          <img src="https://cdn.vox-cdn.com/uploads/blog/sbnu_logo/55/large_Mile_High_Report_Full.162116.png" class="">

        
        <span class="u-hidden-text">Chorus</span>
      </a>
    </div>

    <div class="c-footer__section c-footer__section-links">
      <ul class="u-list-dot-sep">
        
          <li><a rel="nofollow" href="/fanposts">FanPosts</a></li>
        
          <li><a rel="nofollow" href="/fanshots">FanShots</a></li>
        
          <li><a rel="nofollow" href="/masthead">Masthead</a></li>
        
          <li><a rel="nofollow" href="/community-guidelines">Community Guidelines</a></li>
        
          <li><a rel="nofollow" href="http://www.facebook.com/MileHighReport">Facebook</a></li>
        
          <li><a rel="nofollow" href="https://www.twitter.com/MileHighReport">Twitter</a></li>
        
          <li><a rel="nofollow" href="http://www.youtube.com/sbnnfl">YouTube</a></li>
        
      </ul>
    </div>

    <div class="c-footer__section c-footer__section-network">
      <span class="c-footer__network-logo ">
        
          
  <svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewbox="0 0 1000 137.7" enable-background="new 0 0 1000 137.7" xml:space="preserve">
<title>Horizontal - White</title>
<path fill="#FFFFFF" d="M245.3,68.1c11.5,0,20.8-9.1,21.1-20.6c0-7.2,0-12.7,0-12.7C266.5,13.9,253,0,233.7,0h-95v137.7H234
	c16.3,0,32.5-12.5,32.5-33.7V89.2C266.5,77.5,257,68.1,245.3,68.1z M216,98.6c0,1.7-1.3,3-3,3h-23.8v-15h23.6c1.8,0,3.2,1.5,3.2,3.2
	c0,0,0,0,0,0V98.6z M216,46.2c0,1.8-1.5,3.3-3.3,3.3h-23.5V36.1h23.5c1.9,0,3.4,1.5,3.4,3.4L216,46.2z"></path>
<path fill="#FFFFFF" d="M127.7,42.8v-9.1c0-6.6-1.8-13-5.1-18.7l0.1-0.2C117,6,107.4,0.5,96.9,0h-0.1c-0.4,0-0.8,0-1.2,0H32.3
	C14.5,0,0,14.5,0,32.3v18.7l0,0v8.8c0,14.9,12,26.9,26.9,26.9c0,0,0,0,0,0h46.9c1.9,0,3.4,1.5,3.4,3.5l0,0v8c0,1.9-1.6,3.5-3.5,3.5
	H50.5v-6.6H0v10.2c0,6.2,1.8,12.3,5.1,17.5l-0.1,0.2c5.6,8.8,15.3,14.4,25.7,14.8h0.1c0.4,0,0.8,0,1.2,0h63.3
	c17.8,0,32.3-14.4,32.3-32.3l0,0V86.8l0,0V76.4c0-14.9-12-26.9-26.9-26.9h0H53.9c-1.9,0-3.4-1.5-3.4-3.5l0,0v-6.5
	c0-1.9,1.6-3.5,3.5-3.5h23.4v6.7H127.7z"></path>
<rect x="674.1" fill="#FFFFFF" width="50.5" height="137.7"></rect>
<polygon fill="#FFFFFF" points="664.4,0 549.2,0 549.2,36.3 581.6,36.3 581.6,137.7 632,137.7 632,36.3 664.4,36.3 "></polygon>
<path fill="#FFFFFF" d="M830.5,0h-62.8c-17.8,0-32.3,14.5-32.3,32.3v73.1c0,17.8,14.5,32.3,32.3,32.3h62.8
	c17.8,0,32.3-14.5,32.3-32.3V32.3C862.8,14.5,848.4,0,830.5,0L830.5,0z M812.4,98.4c0,1.8-1.5,3.2-3.2,3.2h-20
	c-1.8,0-3.2-1.5-3.2-3.2v-59c0-1.8,1.5-3.2,3.2-3.2h20c1.8,0,3.2,1.5,3.2,3.2V98.4z"></path>
<path fill="#FFFFFF" d="M951,0v49.7L915.8,9.5c-5.1-6-12.6-9.5-20.5-9.5h-21.5v137.7h49V87.8l35.2,40.3c5.1,6,12.6,9.5,20.5,9.5
	h21.5V0H951z"></path>
<path fill="#FFFFFF" d="M354.7,0v49.7L319.4,9.5c-5.1-6-12.6-9.5-20.5-9.5h-21.5v137.7h49V87.8l35.2,40.3c5.1,6,12.6,9.5,20.5,9.5
	h21.5V0H354.7z"></path>
<path fill="#FFFFFF" d="M531.6,17.9C527.8,7.2,517.7,0,506.3,0h-70v36.3h10.5l-35.2,101.3h50.6l7.2-20.8H516l7.2,20.9h50L531.6,17.9
	z M492.6,49.6l10.8,31h-21.4L492.6,49.6z"></path>
</svg>


        
      </span>

      <ul class="u-list-dot-sep">
        
          <li><a rel="nofollow" href="/contact?community_id=247">Contact</a></li>
        
          <li><a rel="nofollow" href="/contact?community_id=247#sports_tips">Have a News Tip?</a></li>
        
          <li><a rel="nofollow" href="http://www.sbnation.com/blogs">Browse Blogs</a></li>
        
          <li><a rel="nofollow" href="/masthead">About SBN</a></li>
        
          <li><a rel="nofollow" href="http://blog.sbnation.com">Company Blog</a></li>
        
          <li><a rel="nofollow" href="http://www.sbnation.com/pages/openings">Blog Openings</a></li>
        
          <li><a rel="nofollow" href="http://www.sbnation.com/guide/disclosure">Editorial Ethics and Guidelines</a></li>
        
      </ul>

      <a rel="nofollow" class="u-block" href="https://www.voxmedia.com"><span class="u-hidden-text">Vox Media</span><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 254.42 33.54" aria-labelledby="title" aria-describedby="description" role="img" class="c-footer__vox-logo"><title id="title">Vox Media</title>
<desc id="description">Vox Media logo.</desc><path d="M229.88,262.35a16.77,16.77,0,1,0,16.77,16.77,16.77,16.77,0,0,0-16.77-16.77m0,25.08a8.32,8.32,0,1,1,7.92-8.31,8.12,8.12,0,0,1-7.92,8.31" transform="translate(-179.16 -262.35)"></path><polygon points="0 0.66 16.97 33.38 33.95 0.66 24.05 0.66 17.07 14.31 10.09 0.66 0 0.66"></polygon><rect x="208.65" y="0.66" width="9" height="32.26"></rect><polygon points="170.15 8.74 170.15 0.66 145.41 0.66 145.41 32.92 170.15 32.92 170.15 24.84 154.82 24.84 154.82 20.68 169.01 20.68 169.01 12.91 154.82 12.91 154.82 8.74 170.15 8.74"></polygon><path d="M367.39,263H353.84v32.27h13.55a16.14,16.14,0,1,0,0-32.27m-.71,24.09h-3.74V271.19h3.74a8,8,0,1,1,0,15.91" transform="translate(-179.16 -262.35)"></path><polygon points="131.07 14.94 131.07 32.92 140.17 32.92 140.17 0.66 128.9 0.66 121.92 14.12 114.94 0.66 103.67 0.66 103.67 32.92 112.57 32.92 112.57 14.94 121.82 32.77 131.07 14.94"></polygon><polygon points="83.11 24.43 88.78 32.93 99.44 32.93 88.44 16.79 99.34 0.66 88.88 0.66 83.21 9.16 83.31 9.16 77.63 0.66 67.08 0.66 77.98 16.79 66.98 32.93 77.43 32.93 83.11 24.43"></polygon><path d="M412.55,284.07l4-11.53,4,11.53ZM422,263H411.38l-11.62,32.27h9l1.41-4.15H423l1.4,4.15h9.21Z" transform="translate(-179.16 -262.35)"></path></svg></a>

      <ul class="u-list-dot-sep">
        
          <li><a rel="nofollow" href="https://www.voxmedia.com/legal/terms-of-use">Terms of Use</a></li>
        
          <li><a rel="nofollow" href="https://www.voxmedia.com/legal/privacy-notice">Privacy Notice</a></li>
        
          <li><a rel="nofollow" href="https://www.voxmedia.com/legal/cookie-policy">Cookie Policy</a></li>
        
          <li><a rel="nofollow" href="/contact#donotsell">Do Not Sell My Personal Info</a></li>
        
          <li><a rel="nofollow" href="https://www.voxmedia.com/pages/licensing">Licensing FAQ</a></li>
        
          <li><a rel="nofollow" href="https://www.voxmedia.com/legal/accessibility">Accessibility</a></li>
        
          <li><a rel="nofollow" href="https://status.voxmedia.com">Platform Status</a></li>
        
        
        
          <li><a rel="nofollow" href="https://www.voxmedia.com/vox-advertising">Advertise with us</a></li>
        
          <li><a rel="nofollow" href="https://jobs.voxmedia.com">Jobs @ Vox Media</a></li>
        
      </ul>
      
    </div>
  </div>

  <div class="l-wrapper c-footer__wrapper">
    <div class="c-footer__section c-footer__section-copy">
        © 2022 <a rel="nofollow" href="https://www.voxmedia.com">Vox Media</a>, LLC. All Rights Reserved
        
          <br>Sports data © STATS 2018
        
    </div>
  </div>

</footer>

    <div class="c-tab-bar " data-cid="site/tab_bar/index-1649516448_4507_358060" data-cdata="{}">
  <a href="/" class="c-tab-bar__logo">
    
      <img src="https://cdn.vox-cdn.com/uploads/blog/sbnu_logo/55/large_Mile_High_Report_Full.162116.png" class="">

    
    
  </a>
  
    
<div class="c-social-buttons" data-analytics-placement="sticky" aria-labelledby="heading-label--aug9ksha" data-cid="site/social_buttons_list-1649516448_1415_358059" data-cdata='{"entry_id":22779148,"services":["twitter","facebook"],"base_url":"https://www.milehighreport.com/2022/4/9/23015107/what-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far"}'>
  <h2 class="sr-only" id="heading-label--aug9ksha">Share this story</h2>
  
    <ul>
      
        
          <li>
            <a class="c-social-buttons__item c-social-buttons__twitter" href="https://twitter.com/intent/tweet?counturl=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far&amp;text=What+do+NFL+Draft+analysts+say+about+the+Broncos%E2%80%99+top+30+NFL+Draft+visits+thus+far%3F&amp;url=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far&amp;via=MileHighReport" data-analytics-social="twitter">
              <svg role="img" class="p-svg-icon c-social-buttons__svg"><use xlink:href="#icon-twitter"></use></svg>
              <span class="c-social-buttons__text">
                Twitter
              </span>
            </a>
          </li>
        
      
        
          <li>
            <a class="c-social-buttons__item c-social-buttons__facebook" href="https://www.facebook.com/sharer/sharer.php?text=What+do+NFL+Draft+analysts+say+about+the+Broncos%E2%80%99+top+30+NFL+Draft+visits+thus+far%3F&amp;u=https%3A%2F%2Fwww.milehighreport.com%2F2022%2F4%2F9%2F23015107%2Fwhat-do-nfl-draft-analysts-say-about-the-broncos-top-30-nfl-draft-visits-thus-far" data-analytics-social="facebook">
              <svg role="img" class="p-svg-icon c-social-buttons__svg"><use xlink:href="#icon-facebook"></use></svg>
              <span class="c-social-buttons__text">
                Facebook
              </span>
            </a>
          </li>
        
      
      
    </ul>
  
</div>

  
  <span class="c-tab-bar__sponsorship"></span>
  
  
</div>

  </div>

      <script src="https://cdn.vox-cdn.com/packs/js/chorus-8ae63447f63dca430b4d.js" async="async" integrity="sha256-bx7JSWDvBgYqWT5EkyCtWVmfID15FljV4wFanhUvpxY= sha384-83gNKzXZnD7U5dyj8j7jZBz0BGROvNLA8EA7iBKLnq89LSqdWJMCSmTx7Eg1PcST" crossorigin="anonymous"></script>
  

      <div id="amzn-assoc-ad-c86ecff2-0781-48c9-a698-200b0643c35a"></div><script defer src="https://z-na.associates-amazon.com/onetag/v2?MarketPlace=US&instanceId=c86ecff2-0781-48c9-a698-200b0643c35a"></script>

      <!-- Phonograph -->

    <script src="https://phonograph2.voxmedia.com/pickup.js?v=1529075019264" id="phonograph-pickup" async="async" defer="defer"></script>

    <script>
      var phonographEvents = phonographEvents || [];
      (function() {
        var continent = document.cookie.match(/_chorus_geoip_continent=([^;]+)/i) || [];
        var data = { 'Page Title':document.title, 'GA Track Prefix':'t1.', 'geoip_continent': continent[1] };
        var dataLayer = window.dataLayer || [];
        dataLayer
          .filter(function(m) { return !!m['Network'] })
          .forEach(function(m) {
            Object.keys(m).forEach(function(k) { data[k] = m[k] });
          });

        var userid = data['Logged in Status'];
        data['User ID'] = (typeof userid === 'number') ? userid : null;
        phonographEvents.push(['pageload', data]);
      })();
    </script>
  <!-- End Phonograph -->

  <script id="parsely-cfg" src="//cdn.parsely.com/keys/milehighreport.com/p.js" defer></script>

    
    
    <!--[if !IE]> -->
<script>
  (function(a,c,d,e){if(!a[c]){var b=a[c]={};b[d]=[];b[e]=function(a){b[d].push(a)}}})(window,'Scroll','_q','do');
  Scroll.config = {
    detected: false
  };
</script>
<script src="https://static.scroll.com/js/scroll.js" async="async"></script>
<!-- <![endif]-->

    
</body></html>


<script type="text/javascript">
  window.onload = function() {
    var links = document.querySelector('.c-entry-content').querySelectorAll('p [has-subtag="true"], li [has-subtag="true"], div [has-subtag="true"]');
    links.forEach(link => {
      var subtagData = link.getAttribute('data-cdata');
      if (subtagData) {
        window.Subtags(link, JSON.parse(subtagData));
      }
    });
  }
</script>
